This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1261249 - f23 beta - locale not set right in cloud images
f23 beta - locale not set right in cloud images
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: spin-kickstarts (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 00:05 EDT by Dusty Mabe
Modified: 2015-09-29 04:56 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-14 14:48:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Work around BZ1262040 (648 bytes, patch)
2015-09-10 14:19 EDT, Dusty Mabe
no flags Details | Diff

  None (edit)
Description Dusty Mabe 2015-09-09 00:05:13 EDT
Description of problem:

locale information is not set right in the fedora cloud image. When you log in you see:

localhost login: fedora
Password: 
-bash: warning: setlocale: LC_CTYPE: cannot change locale (en_US.UTF-8): No such file or directory
-bash: warning: setlocale: LC_COLLATE: cannot change locale (en_US.UTF-8): No such file or directory
-bash: warning: setlocale: LC_MESSAGES: cannot change locale (en_US.UTF-8): No such file or directory
-bash: warning: setlocale: LC_NUMERIC: cannot change locale (en_US.UTF-8): No such file or directory
-bash: warning: setlocale: LC_TIME: cannot change locale (en_US.UTF-8): No such file or directory

`dnf reinstall glibc-common` fixes the issue.


How reproducible:
Always


Steps to Reproduce:
1. Start cloud image [1] in openstack or libvirt/kvm

[1] - http://dl.fedoraproject.org/pub/alt/stage/23_Beta_TC4/Cloud_Images/x86_64/Images/Fedora-Cloud-Base-23_Beta_TC4-20150907.x86_64.qcow2
Comment 1 Kevin Fenzi 2015-09-09 12:49:14 EDT
Wouldn't this be more a glibc issue? or is there something to be adjusted in the kickstart?
Comment 2 Dusty Mabe 2015-09-10 14:17:15 EDT
(In reply to Kevin Fenzi from comment #1)
> Wouldn't this be more a glibc issue? or is there something to be adjusted in
> the kickstart?

Yep as it turns out we believe it is a glibc issue but it only manifests itself when run through anaconda. See bug https://bugzilla.redhat.com/show_bug.cgi?id=1262040.
Comment 3 Dusty Mabe 2015-09-10 14:19:03 EDT
Created attachment 1072311 [details]
Work around BZ1262040
Comment 4 kushaldas@gmail.com 2015-09-14 14:48:20 EDT
Fixed in the commit https://git.fedorahosted.org/cgit/spin-kickstarts.git/commit/?h=f23&id=93793acd48735b021a5551790d55c1f225aec5d8

Thank you for the patch.
Comment 5 hannes 2015-09-29 04:28:21 EDT
I'm still seeing this on Fedora 22 images for EC2
Comment 6 Dusty Mabe 2015-09-29 04:47:23 EDT
@hannes - I don't think this was ever an issue for the F22 release images. This bug report was against F23. Can you be more specific about what issue you are seeing?
Comment 7 hannes 2015-09-29 04:56:28 EDT
I'm seeing the same error messages as in the OP, i.e.

/etc/profile.d/lang.sh: line 19: warning: setlocale: LC_CTYPE: cannot change locale (en_US.UTF-8): No such file or directory
/etc/profile.d/lang.sh: line 20: warning: setlocale: LC_COLLATE: cannot change locale (en_US.UTF-8): No such file or directory
/etc/profile.d/lang.sh: line 23: warning: setlocale: LC_MESSAGES: cannot change locale (en_US.UTF-8): No such file or directory
/etc/profile.d/lang.sh: line 26: warning: setlocale: LC_NUMERIC: cannot change locale (en_US.UTF-8): No such file or directory
/etc/profile.d/lang.sh: line 29: warning: setlocale: LC_TIME: cannot change locale (en_US.UTF-8): No such file or directory

when ssh'ing into an instance created from ami-81362db1 which is a FC22 image.

Note You need to log in before you can comment on or make changes to this bug.