Bug 1261260 - [RFE]: Have reads be performed on same bricks for a given file
[RFE]: Have reads be performed on same bricks for a given file
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
Depends On:
Blocks: 1265074 1270705
  Show dependency treegraph
 
Reported: 2015-09-09 01:26 EDT by Pranith Kumar K
Modified: 2016-06-16 09:35 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1265074 1270705 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:35:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pranith Kumar K 2015-09-09 01:26:06 EDT
Description of problem:

    Add a policy in ec to performs reads from same bricks as long as they
    are good. Based on the gfid of the file/directory it determines the
    bricks to be considered for reading.
    

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-09-09 01:32:53 EDT
REVIEW: http://review.gluster.org/12133 (cluster/ec: Implement gfid-hash read-policy) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Vijay Bellur 2015-09-09 06:28:25 EDT
REVIEW: http://review.gluster.org/12133 (cluster/ec: Implement gfid-hash read-policy) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Vijay Bellur 2015-09-11 00:47:50 EDT
REVIEW: http://review.gluster.org/12133 (cluster/ec: Implement gfid-hash read-policy) posted (#3) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 4 Vijay Bellur 2015-09-14 01:18:53 EDT
REVIEW: http://review.gluster.org/12133 (cluster/ec: Implement gfid-hash read-policy) posted (#4) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2015-09-15 22:21:26 EDT
REVIEW: http://review.gluster.org/12133 (cluster/ec: Implement gfid-hash read-policy) posted (#5) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Niels de Vos 2016-06-16 09:35:52 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.