Bug 1261276 - Tier/shd: Tracker bug for tier and shd compatibility
Tier/shd: Tracker bug for tier and shd compatibility
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1260923 1261744 1271733
  Show dependency treegraph
 
Reported: 2015-09-09 02:05 EDT by Mohammed Rafi KC
Modified: 2016-06-16 09:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1261744 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:35:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-09-09 02:05:46 EDT
Description of problem:

Tier and shd are not compatible, the problems include

* afr requires unified name across the grapsh switch
* shd is not starting on a tiered volume.
* volfiles are created in a wrong way
* multiple afr/disperse stacks are possible in a single graph
* heal commands are not compatible with tiering
* self-heal-daemon enable commands need to be supported 


Version-Release number of selected component (if applicable):


How reproducible:

100

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-09-09 02:07:19 EDT
REVIEW: http://review.gluster.org/11962 (tier/shd: create shd volfile for tiering) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-09-09 02:07:21 EDT
REVIEW: http://review.gluster.org/12134 (tiering/volgen: keep afr/ec xlators name constant) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 3 Vijay Bellur 2015-09-09 02:07:28 EDT
REVIEW: http://review.gluster.org/12135 (tier/shd: make shd commands compatible with tiering) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 4 Vijay Bellur 2015-09-09 03:01:32 EDT
REVIEW: http://review.gluster.org/12134 (tiering/volgen: keep afr/ec xlators name constant) posted (#2) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 5 Vijay Bellur 2015-09-09 03:05:13 EDT
REVIEW: http://review.gluster.org/12135 (tier/shd: make shd commands compatible with tiering) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 6 Vijay Bellur 2015-09-09 04:43:15 EDT
REVIEW: http://review.gluster.org/12134 (tiering/volgen: keep afr/ec xlators name constant) posted (#3) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 7 Vijay Bellur 2015-09-09 04:43:17 EDT
REVIEW: http://review.gluster.org/12135 (tier/shd: make shd commands compatible with tiering) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 8 Vijay Bellur 2015-09-18 06:01:06 EDT
REVIEW: http://review.gluster.org/12134 (tiering/volgen: keep afr/ec xlators name constant) posted (#4) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 9 Vijay Bellur 2015-09-18 06:01:08 EDT
REVIEW: http://review.gluster.org/12135 (tier/shd: make shd commands compatible with tiering) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 10 Vijay Bellur 2015-09-18 06:01:10 EDT
REVIEW: http://review.gluster.org/11962 (tier/shd: create shd volfile for tiering) posted (#5) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 11 Mohammed Rafi KC 2015-10-09 01:40:53 EDT
moving back to post state since two more patches need to be merged as part of the bug
Comment 12 Vijay Bellur 2015-10-12 01:10:47 EDT
COMMIT: http://review.gluster.org/11962 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit fdff192b918ca9cd237f3f784c627102377e3661
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Aug 20 12:19:51 2015 +0530

    tier/shd: create shd volfile for tiering
    
    Currently shd graph will only start if it is replicate
    or disperse volume. But in case of tiering, volume type
    will be tier. So we need to start shd if any of the cold
    or hot is compatible with shd volume.
    
    Change-Id: Ic689746ac7d2fc6a9eccdabd8518dc9139829de2
    BUG: 1261276
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/11962
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 13 Vijay Bellur 2015-10-12 07:57:10 EDT
COMMIT: http://review.gluster.org/12135 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 0ef62933649392051e73fe01c028e41baddec489
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Tue Sep 8 13:04:45 2015 +0530

    tier/shd: make shd commands compatible with tiering
    
    tiering volfiles may contain afr and disperse together
    or multiple time based on configuration. And the
    informations for those configurations are stored in
    tier_info. So most of the volgen code generation
    need to be changed to make compatible with it.
    
    Change-Id: I563d1ca6f281f59090ebd470b7fda1cc4b1b7e1d
    BUG: 1261276
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12135
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 14 Niels de Vos 2016-06-16 09:35:52 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.