Bug 1261365 - [SR-IOV] - 'pci-passthrough' vNIC reported as unplugged in UI once running the VM, although the vNICs state is UP and plugged
[SR-IOV] - 'pci-passthrough' vNIC reported as unplugged in UI once running th...
Status: CLOSED DUPLICATE of bug 1261352
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: nobody nobody
Michael Burman
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 04:14 EDT by Michael Burman
Modified: 2016-02-10 14:48 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-10 11:11:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs and screen shots (1.80 MB, application/x-gzip)
2015-09-09 04:14 EDT, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2015-09-09 04:14:12 EDT
Created attachment 1071607 [details]
logs and screen shots

Description of problem:
[SR-IOV] - 'pci-passthrough' vNIC reported as unplugged in UI once running the VM, although the vNICs state is UP and plugged.

Once running a VM with 'pci-passthrough' vNIC(vNIC is plugged), the vNIC changes his state to unplugged in UI, but the actual state of the vNIC reported as plugged in the client's OS. 


vdsm log -->

Traceback (most recent call last):
  File "/usr/share/vdsm/virt/vm.py", line 1384, in _getRunningVmStats
    vm_sample.interval)
  File "/usr/share/vdsm/virt/vmstats.py", line 42, in produce
    networks(vm, stats, first_sample, last_sample, interval)
  File "/usr/share/vdsm/virt/vmstats.py", line 213, in networks
    first_indexes = _find_bulk_stats_reverse_map(first_sample, 'net')
  File "/usr/share/vdsm/virt/vmstats.py", line 340, in _find_bulk_stats_reverse_map
    name_to_idx[stats['%s.%d.name' % (group, idx)]] = idx
KeyError: 'net.0.name'
Thread-35436::INFO::2015-09-09 08:53:55,272::xmlrpc::92::vds.XMLRPCServer::(_process_requests) Request handler for 127.0.0.1:47532 stopped
Thread-35437::ERROR::2015-09-09 08:54:01,080::vm::1387::virt.vm::(_getRunningVmStats) vmId=`c7758e8d-610e-4f43-8504-ed6acf5e2513`::Error fetching vm stats
Traceback (most recent call last):
  File "/usr/share/vdsm/virt/vm.py", line 1384, in _getRunningVmStats
    vm_sample.interval)
  File "/usr/share/vdsm/virt/vmstats.py", line 42, in produce
    networks(vm, stats, first_sample, last_sample, interval)
  File "/usr/share/vdsm/virt/vmstats.py", line 213, in networks
    first_indexes = _find_bulk_stats_reverse_map(first_sample, 'net')
  File "/usr/share/vdsm/virt/vmstats.py", line 340, in _find_bulk_stats_reverse_map
    name_to_idx[stats['%s.%d.name' % (group, idx)]] = idx
KeyError: 'net.0.name'


Version-Release number of selected component (if applicable):
3.6.0-0.13.master.el6

How reproducible:
50%-90% sometimes

Steps to Reproduce:
1. SR-IOV setup , enable 1 VF on host
2. Create network with 'passthrough' profile and add vNIC with this profile to VM(pci-passthrough type)
3. Run VM

Actual results:
vNIC changes his state to unplugged once starting the VM in the UI.
vNIC reported as plugged in the client's OS and vNIC got ip from dhcp.

Expected results:
vNIC shouldn't change his state to unplugged in the UI. should stay plugged and UI should report that vNIC plugged.
Comment 1 Michael Burman 2015-09-10 11:11:12 EDT
This bug was created 6 times for some reason, closing as duplicate to BZ 1261352

*** This bug has been marked as a duplicate of bug 1261352 ***

Note You need to log in before you can comment on or make changes to this bug.