Bug 126137 - net related processes stuck in 'D' state after ppp0 goes down (kernel-2.6.6-1.427)
net related processes stuck in 'D' state after ppp0 goes down (kernel-2.6.6-1...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-16 12:15 EDT by JuanJo Ciarlante
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: kernel-2.6.6-1.435
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-16 13:16:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description JuanJo Ciarlante 2004-06-16 12:15:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
This ppp0 is actually pppoe for an ADSL link.
When the ADSL provider kicks the connection and ppp0 goes down, 
several processes get stuck in 'D' state, "ps ax" excerpt:
   2515 ?        D      0:06 nmbd -D
   2589 ?        D      0:02 cupsd
  17254 ?        D      0:00 ip route list match 0/0
  17291 pts/12   D      0:00 ifconfig -a             #me digging

_and_ kernel bitchs forever (heh .. actually several HOURS...) with:
  Jun 15 06:53:56 gatew kernel: unregister_netdevice: \
         waiting for ppp0 to become free. Usage count = 1
, only solution is rebooting.

This is REPEATABLE, SAME effect with stock 2.6.7-rc3,
and doesn't happen  FOR SURE with kernel-2.6.5-1.358;
I _guess_ it should be the same for 2.6.6-1.435 (only FP bug update).

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.427

How reproducible:
Always

Steps to Reproduce:
1. get ADSL (maybe any ppp*?) up
2. force line down (eg. disconnect cable)
3. ps ax| egrep ' [D] '; tail /var/log/messages
    

Actual Results:  syslogd 'write' to root:
 Jun 15 06:53:56 gatew kernel: unregister_netdevice: \
         waiting for ppp0 to become free. Usage count = 1

Expected Results:  ppp0 should go down nicely and restart normaly
(from ifcfg-ppp0)

Additional info:
Comment 1 JuanJo Ciarlante 2004-06-16 12:41:21 EDT
I'm now running 2.6.7 (-skas3), and I could not reproduce the BUG :(
by disconnecting the cable, nor by killall -v -1 pppd pppoe.
I'll wait for 'daily' (suckin) ADSL provider disconnection, but I
assumed pppoe/pppd death should have trigger this.

Digging /var/log/messages:
Jun 15 14:12:36 gatew pppd[3967]: LCP terminated by peer
Jun 15 14:12:36 gatew pppoe[3968]: Session 3672 terminated -- received
PADT from peer
Jun 15 14:12:36 gatew pppoe[3968]: Sent PADT
Jun 15 14:12:36 gatew pppd[3967]: Modem hangup
Jun 15 14:12:36 gatew pppd[3967]: Connection terminated.
Jun 15 14:12:36 gatew pppd[3967]: Connect time 360.1 minutes.
Jun 15 14:12:36 gatew pppd[3967]: Sent 88612436 bytes, received
659521987 bytes.
Jun 15 14:12:46 gatew kernel: unregister_netdevice: waiting for ppp0
to become free. Usage count = 1
Jun 15 14:13:17 gatew last message repeated 3 times
Jun 15 14:13:48 gatew last message repeated 3 times
Jun 15 14:13:49 gatew arpwatch: bogon 200.5.118.97 0:2:16:60:65:b0
Jun 15 14:13:49 gatew last message repeated 2 times
Jun 15 14:13:58 gatew kernel: unregister_netdevice: waiting for ppp0
to become free. Usage count = 1
Jun 15 14:14:29 gatew last message repeated 3 times
Jun 15 14:15:39 gatew last message repeated 7 times
Jun 15 14:16:49 gatew last message repeated 7 times
Jun 15 14:17:29 gatew last message repeated 4 times
Comment 2 Dave Jones 2004-06-16 13:03:25 EDT
435 should actually have this fixed.

Note You need to log in before you can comment on or make changes to this bug.