Bug 1261387 - webadmin portal allows to add non-ascii characters in the disk_description which causes false positive object creation in log.
webadmin portal allows to add non-ascii characters in the disk_description wh...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.5.1
All Linux
medium Severity medium
: ovirt-3.5.6
: 3.5.6
Assigned To: Idan Shaby
Aharon Canan
storage
: Regression, ZStream
Depends On: 1219680
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 04:44 EDT by rhev-integ
Modified: 2016-02-10 12:06 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1219680
Environment:
Last Closed: 2015-12-01 14:06:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45374 master MERGED core: encode non-ASCII disk alias/description Never
oVirt gerrit 45900 ovirt-engine-3.6 MERGED core: encode non-ASCII disk alias/description Never
oVirt gerrit 45926 ovirt-engine-3.5 MERGED core: encode non-ASCII disk alias/description Never

  None (edit)
Comment 3 Aharon Canan 2015-11-04 11:13:49 EST
No failure, verified using vt18

from engine.log - 
=================
2015-11-04 18:10:23,794 INFO  [org.ovirt.engine.core.bll.tasks.AsyncTaskManager] (DefaultQuartzScheduler_Worker-39) Setting new tasks map. The map contains now 0 tasks
2015-11-04 18:10:23,795 INFO  [org.ovirt.engine.core.bll.tasks.AsyncTaskManager] (DefaultQuartzScheduler_Worker-39) Cleared all tasks of pool 00000002-0002-0002-0002-000000000331.
2015-11-04 18:10:43,370 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (ajp-/127.0.0.1:8702-1) [ca6941b] Lock Acquired to object EngineLock [exclusiveLocks= key: 245db36b-a44f-4553-8166-0e9710c210b9 value: VM_DISK_BOOT
, sharedLocks= key: 245db36b-a44f-4553-8166-0e9710c210b9 value: VM
]
2015-11-04 18:10:43,493 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (ajp-/127.0.0.1:8702-1) [ca6941b] Running command: UpdateVmDiskCommand internal: false. Entities affected :  ID: ee7cffc2-a1fc-4eaa-9aeb-7b9740c9998a Type: DiskAction group EDIT_DISK_PROPERTIES with role type USER
2015-11-04 18:10:43,603 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (ajp-/127.0.0.1:8702-1) [ca6941b] START, SetVolumeDescriptionVDSCommand( storagePoolId = 00000002-0002-0002-0002-000000000331, ignoreFailoverLimit = false, storageDomainId = f804ba03-2fba-4820-9f23-dd3ab29a5cb9, imageGroupId = ee7cffc2-a1fc-4eaa-9aeb-7b9740c9998a, imageId = 2c48feaa-e802-4dfb-9bc4-1f9c229edca2), log id: 15c0b55a
2015-11-04 18:10:43,603 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (ajp-/127.0.0.1:8702-1) [ca6941b] -- executeIrsBrokerCommand: calling 'setVolumeDescription' 
2015-11-04 18:10:43,604 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (ajp-/127.0.0.1:8702-1) [ca6941b] -- setVolumeDescription parameters:
                spUUID=00000002-0002-0002-0002-000000000331
                sdUUID=f804ba03-2fba-4820-9f23-dd3ab29a5cb9
                imageGroupGUID=ee7cffc2-a1fc-4eaa-9aeb-7b9740c9998a
                volUUID=2c48feaa-e802-4dfb-9bc4-1f9c229edca2
                description={"DiskAlias":"VM01_Disk1","DiskDescription":"e100e900ed00f300fa00f100f100f100","Enc":"2"}

2015-11-04 18:10:45,329 INFO  [org.ovirt.engine.core.vdsbroker.irsbroker.SetVolumeDescriptionVDSCommand] (ajp-/127.0.0.1:8702-1) [ca6941b] FINISH, SetVolumeDescriptionVDSCommand, log id: 15c0b55a
2015-11-04 18:10:45,425 INFO  [org.ovirt.engine.core.bll.UpdateVmDiskCommand] (ajp-/127.0.0.1:8702-1) [ca6941b] Lock freed to object EngineLock [exclusiveLocks= key: 245db36b-a44f-4553-8166-0e9710c210b9 value: VM_DISK_BOOT
, sharedLocks= key: 245db36b-a44f-4553-8166-0e9710c210b9 value: VM
]
2015-11-04 18:10:45,469 INFO  [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector] (ajp-/127.0.0.1:8702-1) [ca6941b] Correlation ID: ca6941b, Call Stack: null, Custom Event ID: -1, Message: VM VM01 VM01_Disk1 disk was updated by admin@internal.
Comment 5 errata-xmlrpc 2015-12-01 14:06:05 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2531.html

Note You need to log in before you can comment on or make changes to this bug.