Bug 1261404 - No quota API to get real hard-limit value.
No quota API to get real hard-limit value.
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: quota (Show other bugs)
mainline
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Manikandan
: Triaged
Depends On: 1250735 1267817
Blocks: 1263075
  Show dependency treegraph
 
Reported: 2015-09-09 05:09 EDT by Manikandan
Modified: 2016-06-16 09:35 EDT (History)
4 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1250735
: 1263075 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:35:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manikandan 2015-09-09 05:09:32 EDT
+++ This bug was initially created as a clone of Bug #1250735 +++

Description of problem: The quota list command returns rounded hard-limit value. If it is rounded it could not be used to restore the quota configuration settings. For example, the hard-limit is set 3080MB, but the quota list returns 3.0GB as a hard-limit value. User has to maintain its own records about true hard-limit values or to use getfattr to check extended attributes.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-09-09 05:17:57 EDT
REVIEW: http://review.gluster.org/12137 (quota : xml output modified to give exact available space in bytes) posted (#1) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 2 Vijay Bellur 2015-09-09 10:42:53 EDT
REVIEW: http://review.gluster.org/12137 (quota : xml output modified to give exact available space in bytes) posted (#2) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 3 Vijay Bellur 2015-09-10 01:40:17 EDT
REVIEW: http://review.gluster.org/12137 (quota : xml output modified to give exact available space in bytes.) posted (#3) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 4 Vijay Bellur 2015-09-10 05:14:32 EDT
REVIEW: http://review.gluster.org/12137 (quota : xml output modified to give exact available space in bytes) posted (#4) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 5 Vijay Bellur 2015-09-11 09:20:39 EDT
REVIEW: http://review.gluster.org/12137 (quota : xml output modified to give exact available space in bytes) posted (#5) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 6 Vijay Bellur 2015-09-15 07:54:39 EDT
REVIEW: http://review.gluster.org/12137 (quota : xml output modified to give exact available space in bytes) posted (#6) for review on master by Manikandan Selvaganesh (mselvaga@redhat.com)
Comment 7 Niels de Vos 2016-06-16 09:35:52 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.