Bug 1261416 - virt-install: Should default to virtio for network and storage on ppc64
virt-install: Should default to virtio for network and storage on ppc64
Status: CLOSED DUPLICATE of bug 1206097
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager (Show other bugs)
7.2
ppc64le Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Pavel Hrdina
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 05:37 EDT by Andrea Bolognani
Modified: 2015-11-03 10:35 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-03 10:35:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrea Bolognani 2015-09-09 05:37:59 EDT
Description of problem:

  virt-install defaults to rtl8139 for network and spapr-vscsi
  for storage; both are pretty poor choices for ppc64 guests.

  virtio should be used instead.


Version-Release number of selected component (if applicable):

  virt-install-1.2.1-6.el7.noarch
  libvirt-client-1.2.17-8.el7.ppc64le


How reproducible:
 
  Always.


Steps to Reproduce:

  I usually use something like

    virt-install \
      --name guest \
      --location http://... /
      --ram 2048 \
      --vcpus 8 \
      --accelerate \
      --os-variant rhel7.0 \
      --graphics none \
      --network network=default \
      --disk size=10,bus=scsi 

  to install guests.


Actual results:

  The guest uses rtl8139 for network and spapr-vscsi for storage.


Expected results:

  virtio is used for both network and storage.


Additional info:

  The same seems to happen when using virt-manager from a Fedora
  22 host instead. I guess the code responsible for picking
  defaults is shared.
Comment 2 Pavel Hrdina 2015-11-03 10:35:42 EST
It's libvirt who selects default devices and this upstream commint in libvirt 75036c69 fixes the way how libvirt selects the default network device for guest.

With the disk, there is no spapr-vscsi storage bus, this was a bug and was fixed by commit 745fa9fa in virt-manager.  The disk bus is scsi and there is a scsi controller spapr-vscsi with spapr-vio address type.

Closing as a duplicate of a virt-manager bug, that's already fixed in rhel-7.2.  If you would like to track the issue for libvirt, but I don't think it's necessary, you can create a new bug.

*** This bug has been marked as a duplicate of bug 1206097 ***

Note You need to log in before you can comment on or make changes to this bug.