Bug 1261439 - blivet.errors.DeviceError: ('cannot replace active format', 'pv00')
blivet.errors.DeviceError: ('cannot replace active format', 'pv00')
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: python-blivet (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
abrt_hash:3aa7d7c63372f769e1feee0c6f8...
:
Depends On:
Blocks: F23BetaBlocker
  Show dependency treegraph
 
Reported: 2015-09-09 06:35 EDT by Vratislav Podzimek
Modified: 2015-09-16 14:35 EDT (History)
9 users (show)

See Also:
Fixed In Version: 23.19.4-1.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-16 14:35:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (630.81 KB, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: anaconda.log (25.72 KB, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: dnf.log (488 bytes, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: environ (494 bytes, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: lsblk_output (4.12 KB, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: nmcli_dev_list (1.20 KB, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: os_info (451 bytes, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: storage.log (342.56 KB, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: syslog (70.01 KB, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: ifcfg.log (1.91 KB, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: packaging.log (50 bytes, text/plain)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details
File: program.log (103.37 KB, application/octet-stream)
2015-09-09 06:36 EDT, Vratislav Podzimek
no flags Details

  None (edit)
Description Vratislav Podzimek 2015-09-09 06:35:58 EDT
Description of problem:
Tried to remove a preexisting LVM on RAID storage setup to reclaim space. There are more storage setups that would trigger this (e.g. LVM thin provisioning with multiple thin LVs)

Version-Release number of selected component:
anaconda-24.0-1

The following was filed automatically by anaconda:
anaconda 24.0-1 exception report
Traceback (most recent call first):
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 695, in _setFormat
    raise errors.DeviceError("cannot replace active format", self.name)
  File "/usr/lib/python3.4/site-packages/blivet/devices/storage.py", line 740, in <lambda>
    lambda d,f: d._setFormat(f),
  File "/usr/lib/python3.4/site-packages/blivet/deviceaction.py", line 669, in apply
    self.device.format = None
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 323, in registerAction
    action.apply()
  File "/usr/lib/python3.4/site-packages/blivet/devicetree.py", line 275, in recursiveRemove
    self.registerAction(ActionDestroyFormat(leaf))
  File "/usr/lib/python3.4/site-packages/blivet/blivet.py", line 611, in recursiveRemove
    self.devicetree.recursiveRemove(device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 422, in _recursiveRemove
    self.storage.recursiveRemove(device)
  File "/usr/lib64/python3.4/site-packages/pyanaconda/ui/gui/spokes/lib/resize.py", line 447, in _scheduleActions
    self._recursiveRemove(device)
blivet.errors.DeviceError: ('cannot replace active format', 'pv00')

Additional info:
addons:         com_redhat_kdump
cmdline:        /usr/bin/python3  /sbin/anaconda
cmdline_file:   inst.stage2=http://192.168.122.1/virtuals inst.geoloc=0 nokill #updates=http://192.168.122.1/virtuals/updates.img #ks=http://192.168.122.1/virtuals/ks_lvm-cache_test.cfg
dnf.rpm.log:    Sep 09 10:32:50 INFO --- logging initialized ---
executable:     /sbin/anaconda
hashmarkername: anaconda
kernel:         4.2.0-1.fc24.x86_64
product:        Fedora
release:        Cannot get release name.
type:           anaconda
version:        Rawhide
Comment 1 Vratislav Podzimek 2015-09-09 06:36:04 EDT
Created attachment 1071673 [details]
File: anaconda-tb
Comment 2 Vratislav Podzimek 2015-09-09 06:36:06 EDT
Created attachment 1071674 [details]
File: anaconda.log
Comment 3 Vratislav Podzimek 2015-09-09 06:36:07 EDT
Created attachment 1071675 [details]
File: dnf.log
Comment 4 Vratislav Podzimek 2015-09-09 06:36:08 EDT
Created attachment 1071676 [details]
File: environ
Comment 5 Vratislav Podzimek 2015-09-09 06:36:09 EDT
Created attachment 1071677 [details]
File: lsblk_output
Comment 6 Vratislav Podzimek 2015-09-09 06:36:11 EDT
Created attachment 1071678 [details]
File: nmcli_dev_list
Comment 7 Vratislav Podzimek 2015-09-09 06:36:12 EDT
Created attachment 1071679 [details]
File: os_info
Comment 8 Vratislav Podzimek 2015-09-09 06:36:16 EDT
Created attachment 1071680 [details]
File: storage.log
Comment 9 Vratislav Podzimek 2015-09-09 06:36:18 EDT
Created attachment 1071681 [details]
File: syslog
Comment 10 Vratislav Podzimek 2015-09-09 06:36:19 EDT
Created attachment 1071682 [details]
File: ifcfg.log
Comment 11 Vratislav Podzimek 2015-09-09 06:36:21 EDT
Created attachment 1071683 [details]
File: packaging.log
Comment 12 Vratislav Podzimek 2015-09-09 06:36:23 EDT
Created attachment 1071684 [details]
File: program.log
Comment 13 Vratislav Podzimek 2015-09-09 06:43:08 EDT
Reported from Rawhide installation, but this also happens in F23. Also, it is a blivet issue not in anaconda.
Comment 14 Fedora Blocker Bugs Application 2015-09-09 06:50:59 EDT
Proposed as a Blocker for 23-beta by Fedora user vpodzime using the blocker tracking app because:

 This clearly violates the last point of the following criteria:
============
When using the guided partitioning flow, the installer must be able to:

    Cleanly install to a disk with a valid ms-dos or gpt disk label and partition table which contains existing data and sufficient unpartitioned space for a Fedora installation
    Complete an installation using any combination of disk configuration options it allows the user to select
    Remove existing storage volumes to free up space, at the user's direction 
============
Comment 15 Adam Williamson 2015-09-10 15:23:49 EDT
Discussed at 2015-09-10 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-09-10/f23-blocker-review.2015-09-10-16.00.log.txt . Accepted as a blocker per criterion cited in #c14.
Comment 16 Fedora Update System 2015-09-14 13:21:53 EDT
python-blivet-1.12.4-1.fc23 anaconda-23.19.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15846
Comment 17 Fedora Update System 2015-09-15 12:50:45 EDT
anaconda-23.19.4-1.fc23, python-blivet-1.12.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update anaconda python-blivet'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15846
Comment 18 Fedora Update System 2015-09-16 14:35:37 EDT
anaconda-23.19.4-1.fc23, python-blivet-1.12.4-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.