Bug 1261441 - ceph-deploy forgetkeys doesn't remove rgw keyring file
ceph-deploy forgetkeys doesn't remove rgw keyring file
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Installer (Show other bugs)
1.3.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3.2
Assigned To: Travis Rhoden
ceph-qe-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 06:44 EDT by Harish NV Rao
Modified: 2016-02-29 09:43 EST (History)
5 users (show)

See Also:
Fixed In Version: RHEL: ceph-deploy-1.5.27.4-1.el7cp Ubuntu: ceph-deploy_1.5.27.4-3redhat1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-29 09:43:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Ceph Project Bug Tracker 12999 None None None Never

  None (edit)
Description Harish NV Rao 2015-09-09 06:44:07 EDT
Description of problem:

ceph-deploy forgetkeys command doesn't remove rgw keyring file.

[cephuser@Admin ceph-config]$ ceph-deploy forgetkeys
[ceph_deploy.conf][DEBUG ] found configuration file at: /home/cephuser/.cephdeploy.conf
[ceph_deploy.cli][INFO  ] Invoked (1.5.25): /usr/bin/ceph-deploy forgetkeys
[cephuser@Admin ceph-config]$ ll
total 140
-rwxrwxrwx. 1 cephuser cephuser     71 Sep  4 07:50 ceph.bootstrap-rgw.keyring
-rwxrwxrwx. 1 cephuser cephuser    603 Sep  4 07:36 ceph.conf
-rwxrwxrwx. 1 cephuser cephuser 128879 Sep  4 13:17 ceph.log

Version-Release number of selected component (if applicable): 
ceph: 0.94.2
ceph-deploy: 1.5.25


How reproducible:always


Steps to Reproduce:
1. run ceph-deploy forgetkeys 

Actual results:
ceph.bootstrap-rgw.keyring is not removed

Expected results:
ceph.bootstrap-rgw.keyring is removed

Additional info:
Comment 2 Travis Rhoden 2015-09-09 12:16:29 EDT
Easy fix.  upstream review at https://github.com/ceph/ceph-deploy/pull/352
Comment 4 Hemanth Kumar 2016-02-02 03:11:36 EST
rgw keyring is getting removed now... Moving to verified state.

ubuntu@magna012:~/install/ubuntu/u130/ceph-config$ ls
ceph.bootstrap-osd.keyring  ceph.client.admin.keyring  cephdeploy.conf  ceph.mon.keyring  ceph.bootstrap-mds.keyring   ceph.bootstrap-rgw.keyring  ceph.conf    ceph.log         

ubuntu@magna012:~/install/ubuntu/u130/ceph-config$ ceph-deploy forgetkeys
[ceph_deploy.conf][DEBUG ] found configuration file at: /home/ubuntu/install/ubuntu/u130/ceph-config/cephdeploy.conf
[ceph_deploy.cli][INFO  ] Invoked (1.5.27.4): /usr/bin/ceph-deploy forgetkeys
[ceph_deploy.cli][INFO  ] ceph-deploy options:
[ceph_deploy.cli][INFO  ]  username                      : None
[ceph_deploy.cli][INFO  ]  verbose                       : False
[ceph_deploy.cli][INFO  ]  overwrite_conf                : False
[ceph_deploy.cli][INFO  ]  quiet                         : False
[ceph_deploy.cli][INFO  ]  cd_conf                       : <ceph_deploy.conf.cephdeploy.Conf instance at 0x7f06220ac758>
[ceph_deploy.cli][INFO  ]  cluster                       : ceph
[ceph_deploy.cli][INFO  ]  func                          : <function forgetkeys at 0x7f062299ff50>
[ceph_deploy.cli][INFO  ]  ceph_conf                     : None
[ceph_deploy.cli][INFO  ]  default_release               : False

ubuntu@magna012:~/install/ubuntu/u130/ceph-config$ ls
ceph.conf  cephdeploy.conf  ceph.log

ubuntu@magna012:~/install/ubuntu/u130/ceph-config$
Comment 6 errata-xmlrpc 2016-02-29 09:43:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:0313

Note You need to log in before you can comment on or make changes to this bug.