This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1261449 - Met error when docker build's source code's format is 'git://github.com/<repo>.git'
Met error when docker build's source code's format is 'git://github.com/<repo...
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Michal Fojtik
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 07:03 EDT by zhou ying
Modified: 2015-09-22 15:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: openshift-3.0.1.900-0.git.251.56c53fd.el7ose.x86_64
Doc Type: Bug Fix
Doc Text:
Cause: Git URI parsing did not handle git:// style URIs. Consequence: Builds that used git:// style GIT URIs would fail. Fix: GIT URI parsing has been updated to account for git:// style URIs. Result: Builds using git:// style GIT URIs will not work properly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-22 15:52:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description zhou ying 2015-09-09 07:03:19 EDT
Description of problem:
When source code's format is 'git://' to create a docker build app, met error, and build failed.
        "source": {
          "type": "Git",
          "git": {
            "uri": "git://github.com/openshift/ruby-hello-world.git"
          }
        },


Version-Release number of selected component (if applicable):
oc v3.0.1.900-185-g2f7757a
kubernetes v1.1.0-alpha.0-1605-g44c91b1

How reproducible:
Always

Steps to Reproduce:
1. Create a project;
2. Use command to create a docker build:
   `oc  new-app application-template-dockerbuild.json`
3. Check build status and build log;

Actual results:
The build always failed, the logs like this:
[zhouy@zhouy Work]$ oc get build
NAME                  TYPE      STATUS    POD
ruby-sample-build-1   Docker    Failed    ruby-sample-build-1-build
[zhouy@zhouy Work]$ oc build-logs ruby-sample-build-1
F0909 05:52:10.542511       1 builder.go:47] Build error: dial tcp: missing port in address github.com

Expected results:
The build should successfully.

Additional info:
When use origin env , the docker build can successfully.
Comment 2 Ben Parees 2015-09-09 12:09:31 EDT
fixed here: https://github.com/openshift/origin/pull/4573
Comment 4 zhou ying 2015-09-11 04:22:54 EDT
Confirmed on :
oc v3.0.1.900-185-g2f7757a
kubernetes v1.1.0-alpha.0-1605-g44c91b

The bug fixed, and works well:
[root@dhcp-136-93 ~]# oc get build
NAME                  TYPE      STATUS     POD
ruby-sample-build-1   Docker    Complete   ruby-sample-build-1-build
Comment 6 errata-xmlrpc 2015-09-22 15:52:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:1835

Note You need to log in before you can comment on or make changes to this bug.