Bug 1261463 - AFR : [RFE] Improvements needed in "gluster volume heal info" commands
AFR : [RFE] Improvements needed in "gluster volume heal info" commands
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: replicate (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Mohamed Ashiq
: FutureFeature
Depends On: 1047493
Blocks: 1493422
  Show dependency treegraph
 
Reported: 2015-09-09 07:44 EDT by Mohamed Ashiq
Modified: 2017-12-08 12:31 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.13.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1047493
: 1493422 (view as bug list)
Environment:
Last Closed: 2017-12-08 12:31:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-09-10 14:04:03 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status and count of entries to be healed) posted (#1) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 2 Vijay Bellur 2015-09-15 12:21:30 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status and count of entries to be healed) posted (#2) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 3 Mike McCune 2016-03-28 19:08:19 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 4 Vijay Bellur 2016-08-10 04:22:25 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status of brick and count of entries to be healed) posted (#4) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 5 Vijay Bellur 2016-08-19 03:11:10 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status of brick and count of entries to be healed) posted (#5) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 6 Worker Ant 2016-08-31 01:26:37 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status of brick and count of entries to be healed) posted (#6) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 7 Worker Ant 2016-08-31 06:18:30 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status of brick and count of entries to be healed) posted (#7) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 8 Worker Ant 2016-09-21 03:52:29 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status of brick and count of entries to be healed) posted (#8) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 9 Worker Ant 2016-09-27 06:48:32 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status of brick and count of entries to be healed) posted (#9) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 10 Worker Ant 2016-10-07 01:00:13 EDT
REVIEW: http://review.gluster.org/12154 (heal: New feature heal info summary to list the status of brick and count of entries to be healed) posted (#10) for review on master by Mohamed Ashiq Liyazudeen (mliyazud@redhat.com)
Comment 11 Worker Ant 2017-09-13 03:15:11 EDT
REVIEW: https://review.gluster.org/12154 (heal: New feature heal info summary to list the status of brick and count of entries to be healed) posted (#11) for review on master by Karthik U S (ksubrahm@redhat.com)
Comment 12 Worker Ant 2017-09-15 08:21:40 EDT
COMMIT: https://review.gluster.org/12154 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit dabfc3116ae59b331f967c090c0c51eb3f0355fd
Author: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
Date:   Wed Aug 10 13:44:19 2016 +0530

    heal: New feature heal info summary to list the status of brick and count of entries to be healed
    
    Command output:
    Brick 192.168.2.8:/brick/1
    Status: Connected
    Total Number of entries: 363
    Number of entries in heal pending: 362
    Number of entries in split-brain: 0
    Number of entries possibly healing: 1
    
    <?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <cliOutput>
      <healInfo>
        <bricks>
          <brick hostUuid="9105dd4b-eca8-4fdb-85b2-b81cdf77eda3">
            <name>192.168.2.8:/brick/1</name>
            <status>Connected</status>
            <totalNumberOfEntries>363</numberOfEntries>
            <numberOfEntriesInHealPending>362</numberOfEntriesInHealPending>
            <numberOfEntriesInSplitBrain>0</numberOfEntriesInSplitBrain>
            <numberOfEntriesPossiblyHealing>1</numberOfEntriesPossiblyHealing>
          </brick>
        </bricks>
      </healInfo>
      <opRet>0</opRet>
      <opErrno>0</opErrno>
      <opErrstr/>
    </cliOutput>
    
    Change-Id: I40cb6f77a14131c9e41b292f4901b41a228863d7
    BUG: 1261463
    Signed-off-by: Mohamed Ashiq Liyazudeen <mliyazud@redhat.com>
    Reviewed-on: https://review.gluster.org/12154
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Tested-by: Karthik U S <ksubrahm@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 13 Shyamsundar 2017-12-08 12:31:43 EST
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.13.0, please open a new bug report.

glusterfs-3.13.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-December/000087.html
[2] https://www.gluster.org/pipermail/gluster-users/

Note You need to log in before you can comment on or make changes to this bug.