Bug 1261464 - Changing font color doesn't always work
Changing font color doesn't always work
Status: NEW
Product: Fedora
Classification: Fedora
Component: lxpanel (Show other bugs)
26
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 07:46 EDT by Giulio 'juliuxpigface'
Modified: 2017-04-30 05:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-20 09:36:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
STEP 2 - Right-click on lxpanel (620.23 KB, image/png)
2015-09-10 02:01 EDT, Giulio 'juliuxpigface'
no flags Details
STEP 3 - Navigate to the second tab (Appearance) (552.42 KB, image/png)
2015-09-10 02:02 EDT, Giulio 'juliuxpigface'
no flags Details
STEP 4 - Select a custom character color (light-green in this screenshot) (552.81 KB, image/png)
2015-09-10 02:02 EDT, Giulio 'juliuxpigface'
no flags Details

  None (edit)
Description Giulio 'juliuxpigface' 2015-09-09 07:46:31 EDT
Description of problem:
I can't set a custom color for the character of lxpanel. The compose I'm currently testing on qemu-kvm is 'Fedora-Live-LXDE-i686-23_Beta-TC4.iso'.

Version-Release number of selected component (if applicable):
lxpanel-0.8.1-2.fc23.i686

How reproducible:
Always, at least on this compose.

Steps to Reproduce:
1. Log In to a LXDE session
2. Right-click on lxpanel
3. Navigate to the second tab (my installation is in Italian, I guess it's called 'Look' or something similar)
4. Select a custom character color (e.g.: white)

Actual results:
1. The color doesn't change.

Expected results:
1. The color should change according to user's preferences.

Additional info:
Changing GTK themes appears sometimes (not always) to trigger that custom setting.
Comment 1 Mamoru TASAKA 2015-09-09 10:36:31 EDT
Can you take some screenshots to illustrate your procedure and the result you see?
Comment 2 Giulio 'juliuxpigface' 2015-09-10 02:01:30 EDT
Created attachment 1072021 [details]
STEP 2 - Right-click on lxpanel
Comment 3 Giulio 'juliuxpigface' 2015-09-10 02:02:13 EDT
Created attachment 1072022 [details]
STEP 3 - Navigate to the second tab (Appearance)
Comment 4 Giulio 'juliuxpigface' 2015-09-10 02:02:57 EDT
Created attachment 1072023 [details]
STEP 4 - Select a custom character color (light-green in this screenshot)
Comment 5 Giulio 'juliuxpigface' 2015-09-10 02:12:11 EDT
Hello Mamoru, many thanks for the fast response.

Some additional info:

- I tested this on a live session (always on qemu-kvm) and I can reproduce the issue.
- The correct section is called "Appearance", not "Look", sorry.
- If you take a look to "STEP 4" screenshot, you'll notice that the clock remains black, despite I chose light-green as color.
- Changing width, height and icon size of the panel causes sometimes lxpanel to refresh and correctly change the font color. But this doesn't always work.

Moreover, I tried to launch lxpanel from lxterminal and I've received these kinds of warning while testing (I'm not sure if they're valuable, though):

(lxpanel:2416): Wnck-WARNING **: Unhandled action type _OB_WM_ACTION_UNDECORATE
Comment 6 Mamoru TASAKA 2015-09-16 01:29:57 EDT
Okay, now I tried and it seems that at the timing when the display of the clock actually changes, the color is also updated. So

* when changing width and height of the panel and when the display of the clock actually changes, the color is also updated.
* and my settings of the strftime() format of the lxpanel clock is '%x (%a) %T', with this the clock is updated each second, so the color is updated within 1 second.

I guess currently the best workaround is to call

$ lxpanelctl restart

from the terminal. I will try to debug further later.
Comment 7 Fedora End Of Life 2016-11-24 07:28:37 EST
This message is a reminder that Fedora 23 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 23. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '23'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 23 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 8 Fedora End Of Life 2016-12-20 09:36:10 EST
Fedora 23 changed to end-of-life (EOL) status on 2016-12-20. Fedora 23 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 9 Giulio 'juliuxpigface' 2017-04-30 05:32:55 EDT
Reopening this, as it's reproducible on Fedora 26 too.

Note You need to log in before you can comment on or make changes to this bug.