Bug 126154 - Proxy doesn't have bootstrap files
Proxy doesn't have bootstrap files
Status: CLOSED DUPLICATE of bug 132275
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Server (Show other bugs)
420
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Warner
Vlady Zlatkin
:
Depends On:
Blocks: 130548
  Show dependency treegraph
 
Reported: 2004-06-16 15:22 EDT by greg pryzby
Modified: 2007-10-23 21:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:04:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description greg pryzby 2004-06-16 15:22:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040614 Firefox/0.8

Description of problem:
When a proxy is created, the bootstrap directory is not created on proxy.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Build AS 2.1 machine according to Proxy Guide
2. Install Proxy according to Proxy Guide
3. No pub/bootstrap exists for registration
    

Actual Results:  There is no /var/www/html/pub/bootstrap directory
with files. The files exist on Satellite, but there is no way for a
client who can not talk to Satellite to get the files.

Expected Results:  During an install the pub/bootstrap should be
created and populated. A script to sync between Proxy and Satellite
*might* make sense

Additional info:
Comment 1 Todd Warner 2004-06-20 11:49:40 EDT
Adding the bootstrap script generation facilities to RHN Proxy has
been on my TODO list for some time now. It's a matter of finding the time.

You can easily scp or rsync the necessary scripts to the pub directory
of the RHN Proxy and hand modify the scripts. I know this is not
ideal, but it is also not overly hard. It works fine for the short-term.
Comment 2 greg pryzby 2004-07-12 11:35:01 EDT
Sounds good. I wanted to make sure that someone else thought it was a
good idea and was on a TODO list.

BTW, that is what I did-- setup some foo to check the files and pull
and modify as required.
Comment 3 Todd Warner 2004-07-29 12:26:27 EDT
Done for RHN Proxy 3.5.0, which is not being released, so it should be
in the next version that is released... whatever that is. :)

Test plan start point (for QA guys):
------------------------------------
o rhn-bootstrap tool tests fine on an RHN Proxy (see test plans for
RHN    
  Satellite that has the same tool).
o webUI interface (on RHN sat or hosted) still in flux... that will be
  another bug that gets a seperate test plan.
Comment 4 Todd Warner 2004-07-29 12:30:04 EDT
Docs note:
o docs need to note that if a customer is running an RHN Proxy
  below an RHN Satellite, that creating bootstrap scripts from the RHN 
  Satellite and scping or rsync them to the RHN Proxy may be the easiest
  way to generate them... similar to server-side SSL key-pairs.

  Need to hash this out.


Comment 5 Todd Warner 2004-09-10 12:52:26 EDT
ON_QA -> ASSIGNED
Tool is being modified... and we need to reverify this bug.
Blocking bug changed from rhn350proxy --> bug 132275
Comment 6 Todd Warner 2004-10-20 14:27:21 EDT
Done for 3.6.0

Now to make it work! :)

TEST PLAN:
----------
o follow docs to generate bootstrap scripts (RHEL 2.1 and RHEL 3 
  clients) on an RHN Proxy
o test that you can use scripts against RHN Proxy


DOCS:
-----
o need to reference bootstrap stuff in proxy docs. Not sure where they 
  are in the satellite. I would have to look it up.

Comment 7 Todd Warner 2004-10-21 12:39:25 EDT
QA push. {ON_DEV,QA_READY} --> ON_QA
Comment 8 Vlady Zlatkin 2004-11-17 16:50:41 EST
see bug #134592
Comment 9 Vlady Zlatkin 2004-11-18 13:52:36 EST
once again this is another bug to test the bootstrap tool

*** This bug has been marked as a duplicate of 132275 ***
Comment 10 Red Hat Bugzilla 2006-02-21 14:04:06 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.