This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1261548 - oc run --attach gives error: "cannot attach to DeploymentConfig: not implemented"
oc run --attach gives error: "cannot attach to DeploymentConfig: not implemen...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Fabiano Franz
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 11:27 EDT by Jordan Liggitt
Modified: 2016-01-04 22:00 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 16:16:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jordan Liggitt 2015-09-09 11:27:55 EDT
Extracted from https://bugzilla.redhat.com/show_bug.cgi?id=1258390

When --attach option is carried in 'oc run', there is error info indicating "not implemented"
$ oc run nginx --image=nginx --attach=true. 
error: cannot attach to DeploymentConfig: not implemented
Comment 1 Jordan Liggitt 2015-09-09 12:12:41 EDT
OpenShift overrides the "run" command generator to create a DeploymentConfig instead of a replication controller. We need to also inject handling of `--attach` for that object, since the core command doesn't know what to do with it
Comment 2 openshift-github-bot 2015-10-29 01:16:21 EDT
Commit pushed to master at https://github.com/openshift/origin

https://github.com/openshift/origin/commit/65775d3955417cf81258df83b10a603f068c6b3c
Bug 1261548 - oc run --attach support for DeploymentConfig
Comment 3 yapei 2015-10-29 23:33:08 EDT
Verified on devenv-fedora_2595

oc v1.0.7-32-gd17e473
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4

$ oc run hello-openshift --image=yapei/hello-openshift --attach=true
Waiting for pod yapei-test/hello-openshift-1-isso6 to be running, status is Pending, pod ready: false
Waiting for pod yapei-test/hello-openshift-1-isso6 to be running, status is Pending, pod ready: false
Waiting for pod yapei-test/hello-openshift-1-isso6 to be running, status is Pending, pod ready: false
Waiting for pod yapei-test/hello-openshift-1-isso6 to be running, status is Pending, pod ready: false
Waiting for pod yapei-test/hello-openshift-1-isso6 to be running, status is Pending, pod ready: false
Waiting for pod yapei-test/hello-openshift-1-isso6 to be running, status is Pending, pod ready: false
Started, serving at 8080

it works as expected

Note You need to log in before you can comment on or make changes to this bug.