Bug 1261552 - Extensions from RHEL 7.1 don't work on 7.2 beta
Extensions from RHEL 7.1 don't work on 7.2 beta
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: 7.2
Assigned To: Florian Müllner
Desktop QE
:
Depends On:
Blocks: 1133060
  Show dependency treegraph
 
Reported: 2015-09-09 11:46 EDT by Brian Gollaher
Modified: 2015-11-19 02:20 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 02:20:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Gollaher 2015-09-09 11:46:08 EDT
Description of problem:
Frippery extensions installed on RHEL 7.1 do not work when gnome-shell is updated to RHEL 7.2 beta

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Frippery panel favorites, Frippery move clock, etc.
2. Upgrade from RHEL 7.1 to RHEL 7.2 beta


Actual results:
Extensions disappear
Tweak tool will not allow them to be turned on

Expected results:
Customer extensions must work when upgrading versions of RHEL.  There is no point offering extensions if RHEL minor releases break them.

Additional info:
Tweak tool flags "Extension does not support shell version"
Comment 1 Matthias Clasen 2015-09-09 11:50:06 EDT
Florian, afaik, the plan was to show a notification that instructs users to update extensions. Did that not land ?
Comment 2 Brian Gollaher 2015-09-09 15:29:58 EDT
Where is the notification supposed to appear?  In tweak tool it implies the wrong version but remove is greyed out and there is no update.  Looking glass says the extensions are out of date.  FF 38 can't detect version of Gnome and the gnome add-on says it is not compatible with FF 38.
Comment 3 Ray Strode [halfline] 2015-09-15 13:02:56 EDT
Brian, do you have gnome-shell-browser-plugin installed? you should be able to update your extensions from extensions.gnome.org
Comment 4 Matthias Clasen 2015-09-18 09:12:11 EDT
I've filed bug 1264436 with some ideas for improved extension handling in gnome-tweak-tool.
Comment 5 Ray Strode [halfline] 2015-09-18 09:23:51 EDT
so I met with Brian yesterday and we discovered that he didn't have gnome-shell-browser-plugin installed, so extensions.gnome.org didn't work for him.  This is, in part, because the browser-plugin package is in workstation-optional instead of workstation.

He ended up getting the frippery extension as an rpm from a 3rd party site, which is why the tweak tool was unable to update it.

Proposals:

1) we have knowledgebase article up front before release that discusses extensions and how any third party ones will need to be manually updated

2) we move the browser-plugin from workstation-optional to workstation.  We still shouldn't have it installed by default, I think, because that may surprise admins on managed workstations.

3) we make sure the tweak tool gets the updtes mclasen proposes in bug 1264436

4) potentially do the notification mentioned in comment 1

I think 1 and 2 are important before 7.2 release, but the others can potentially wait.
Comment 6 Matthias Clasen 2015-09-18 10:19:15 EDT
clearing needinfo
Comment 7 Florian Müllner 2015-09-21 15:26:05 EDT
(In reply to Matthias Clasen from comment #1)
> Florian, afaik, the plan was to show a notification that instructs users to
> update extensions. Did that not land ?

I'm afraid it didn't - let's try to use this bug to land it.
Comment 12 errata-xmlrpc 2015-11-19 02:20:58 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2216.html

Note You need to log in before you can comment on or make changes to this bug.