Bug 1261559 - pyanaconda.bootloader.BootLoaderError: failed to set new efi boot target. This is most likely a kernel or firmware bug.
pyanaconda.bootloader.BootLoaderError: failed to set new efi boot target. Thi...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: python-blivet (Show other bugs)
7.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 12:11 EDT by Brian Lane
Modified: 2015-11-19 03:50 EST (History)
3 users (show)

See Also:
Fixed In Version: python-blivet-0.61.15.27-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 03:50:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2015-09-09 12:11:45 EDT
This is the RHEL version of Fedora Bug #1260799

What it boils down to is that blivet needs to mount /sys/firmware/efi/efivars inside the /mnt/sysimage/ tree during installation so that efibootmgr will work correctly.
Comment 1 Brian Lane 2015-09-09 12:32:24 EDT
Proposed patch - https://github.com/rhinstaller/blivet/pull/221
Comment 4 errata-xmlrpc 2015-11-19 03:50:34 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2232.html

Note You need to log in before you can comment on or make changes to this bug.