Bug 1261562 - [Offscreen surfaces and OMTC] flicker when in-browser notifications are shown or hidden
[Offscreen surfaces and OMTC] flicker when in-browser notifications are shown...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
22
x86_64 Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 12:38 EDT by Christian Stadelmann
Modified: 2015-09-27 05:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-27 05:44:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Stadelmann 2015-09-09 12:38:33 EDT
Description of problem:
This issue happens only with Offscreen surfaces and OMTC enabled as described in https://lists.fedoraproject.org/pipermail/devel/2015-August/213645.html

With "in-browser notifications" I mean those things called GtkInfoBar in Gtk. They show up e.g. when firefox blocks a popup. They are used e.g. by the HTTPS finder addon to tell you that HTTPS was found, or by the requestpolicy addon to ask before forwarding if you disabled automatic redirection.

Version-Release number of selected component (if applicable):
firefox-40.0.3-1.fc22.x86_64, happened on 39.x releases too afaik.

How reproducible:
often

Steps to Reproduce:
1. use a website or addon that displays these notifications. In my case this is RequestPolicyContinued beta from [1] with "block all connections" set to true on about:requestpolicy?defaultpolicy
2. go to https://www.ssllabs.com/ssltest/
3. run the ssl test for any website not cached. Use a rarely known URL. After some time firefox should display a notification bar because RequestPolicyContinued blocked the redirection/page reload.

Actual results:
the website displayed in firefox flickers while fading in and out notification bars.

Expected results:
notification bar should fade in and out without flickering the screen. In fact I don't need the animation at all, but I can't turn it off.

Additional info:
Previously, with OMTC enabled but Offscreen surfaces disabled firefox used to crash in these cases. I reported these crashes to mozilla using the builtin firefox crash reporter. But I stopped doing so since I doubt anyone will look at this over at mozilla. Is there any reason why abrt/libreport is set to not report firefox crashes in /etc/abrt/abrt-action-save-package-data.conf ?

[1] https://requestpolicycontinued.github.io/
Comment 1 Christian Stadelmann 2015-09-10 07:02:02 EDT
I think those are the crash stats from about:crashes:

bp-09064716-4b4a-43ea-ba63-aa0382150816
	16.08.2015	12:54
bp-5c48a5bb-49c1-4daa-a97f-7ecbc2150816
	16.08.2015	12:53
bp-20c55536-e225-45b9-ab60-da2fc2150816
	16.08.2015	12:45
bp-61b5971c-a0bd-4184-961a-cafed2150816
	16.08.2015	12:18
bp-61f86487-ece3-48b2-95a4-6cccf2150816
	16.08.2015	12:18
bp-b871949c-081a-445d-88bd-f41a22150727
	27.07.2015	22:14
bp-80761446-e1fc-4b1c-b74a-3b5ea2150727
	27.07.2015	22:13
bp-0a36ad4f-b80d-4ffa-aa59-5be902150727
	27.07.2015	17:20
bp-0d6cb338-ae0e-48a6-b120-17e8a2150727
	27.07.2015	12:58
Comment 2 Christian Stadelmann 2015-09-27 05:44:57 EDT
This issue is gone after updating firefox from 40.0.3-1 to 41.0-4

Note You need to log in before you can comment on or make changes to this bug.