Bug 1261566 - use ioctl(SIOC[GS]IFHWADDR) to save/set MAC address of macvtap passthrough physdevs with an 802.1Qbh port profile
use ioctl(SIOC[GS]IFHWADDR) to save/set MAC address of macvtap passthrough ph...
Status: CLOSED DUPLICATE of bug 1251532
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.7
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Laine Stump
Virtualization Bugs
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 13:11 EDT by Laine Stump
Modified: 2015-09-30 13:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1257004
Environment:
Last Closed: 2015-09-30 13:18:35 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Laine Stump 2015-09-09 13:11:02 EDT
+++ This bug was initially created as a clone of Bug #1257004 +++

Before libvirt sets the MAC address of the physdev (the physical ethernet device) linked to a macvtap passthrough device, it always saves the previous MAC address to restore when the guest is finished (following a "leave nothing behind" policy). It has even done this for macvtap devices that have an 802.1Qbh port profile attached to them. It turns out that this is unnecessary, because the port profile Associate/Disassociate operations do that for us.

Beyond that, with a recent change to the way we retrieve the MAC address (new in RHEL6.7, thanks to the fix for Bug 1113474, all attempts to start a macvtap passthrough device with an 802.1Qbh port profile attached to a Cisco VMFEX card (which uses the "enic" driver in the kernel) will fail.

--- Additional comment from Laine Stump on 2015-09-03 11:47:04 EDT ---

Fix pushed upstream:

commit 3ce08fab8477da2c76918329523a5e6a312cef06
Author: Laine Stump <laine@laine.org>
Date:   Mon Aug 31 17:09:01 2015 -0400

    util: make virNetDev(Replace|Restore)MacAddress public functions
    
commit 46cf0cefa0168a0d929ca87010f59e1cba6c689b
Author: Laine Stump <laine@laine.org>
Date:   Wed Aug 26 00:18:26 2015 -0400

    util: don't use netlink to save/set mac for macvtap+passthrough+802.1Qbh

Note You need to log in before you can comment on or make changes to this bug.