Bug 1261631 - when creating a shared VG w/o already exisiting PVs, the PV name is displayed three times during the create
Summary: when creating a shared VG w/o already exisiting PVs, the PV name is displayed...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: lvm2
Version: 7.2
Hardware: x86_64
OS: Linux
low
unspecified
Target Milestone: rc
: ---
Assignee: David Teigland
QA Contact: cluster-qe@redhat.com
URL:
Whiteboard:
Depends On:
Blocks: 1313485 1295577
TreeView+ depends on / blocked
 
Reported: 2015-09-09 19:16 UTC by Corey Marthaler
Modified: 2016-11-04 04:10 UTC (History)
7 users (show)

Fixed In Version: lvm2-2.02.152-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 04:10:31 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1445 normal SHIPPED_LIVE lvm2 bug fix and enhancement update 2016-11-03 13:46:41 UTC

Description Corey Marthaler 2015-09-09 19:16:54 UTC
Description of problem:
[root@harding-03 ~]# pvscan
  Skipping global lock: lockspace not found or started
  PV /dev/sda2   VG rhel_harding-03   lvm2 [92.67 GiB / 60.00 MiB free]
  PV /dev/sdb1   VG rhel_harding-03   lvm2 [93.16 GiB / 0    free]
  PV /dev/sdc1   VG rhel_harding-03   lvm2 [93.16 GiB / 0    free]
  Total: 3 [278.98 GiB] / in use: 3 [278.98 GiB] / in no VG: 0 [0   ]

[root@harding-03 ~]#  vgcreate --shared harding /dev/mapper/mpath[abcdefgh]1
  WARNING: shared lock type "sanlock" and lvmlockd are Technology Preview.
  For more information on Technology Preview features, visit:
  https://access.redhat.com/support/offerings/techpreview/
  Enabling sanlock global lock
  Physical volume "/dev/mapper/mpatha1" successfully created
  Physical volume "/dev/mapper/mpathb1" successfully created
  Physical volume "/dev/mapper/mpathc1" successfully created
  Physical volume "/dev/mapper/mpathd1" successfully created
  Physical volume "/dev/mapper/mpathe1" successfully created
  Physical volume "/dev/mapper/mpathf1" successfully created
  Physical volume "/dev/mapper/mpathg1" successfully created
  Physical volume "/dev/mapper/mpathh1" successfully created
  Physical volume "/dev/mapper/mpatha1" successfully created
  Physical volume "/dev/mapper/mpathb1" successfully created
  Physical volume "/dev/mapper/mpathc1" successfully created
  Physical volume "/dev/mapper/mpathd1" successfully created
  Physical volume "/dev/mapper/mpathe1" successfully created
  Physical volume "/dev/mapper/mpathf1" successfully created
  Physical volume "/dev/mapper/mpathg1" successfully created
  Physical volume "/dev/mapper/mpathh1" successfully created
  Logical volume "lvmlock" created.
  Physical volume "/dev/mapper/mpatha1" successfully created
  Physical volume "/dev/mapper/mpathb1" successfully created
  Physical volume "/dev/mapper/mpathc1" successfully created
  Physical volume "/dev/mapper/mpathd1" successfully created
  Physical volume "/dev/mapper/mpathe1" successfully created
  Physical volume "/dev/mapper/mpathf1" successfully created
  Physical volume "/dev/mapper/mpathg1" successfully created
  Physical volume "/dev/mapper/mpathh1" successfully created
  Volume group "harding" successfully created
  VG harding starting sanlock lockspace
  Starting locking.  Waiting until locks are ready...


Version-Release number of selected component (if applicable):
3.10.0-306.el7.x86_64
lvm2-2.02.130-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015
lvm2-libs-2.02.130-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015
lvm2-cluster-2.02.130-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015
device-mapper-1.02.107-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015
device-mapper-libs-1.02.107-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015
device-mapper-event-1.02.107-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015
device-mapper-event-libs-1.02.107-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015
device-mapper-persistent-data-0.5.5-1.el7    BUILT: Thu Aug 13 09:58:10 CDT 2015
cmirror-2.02.130-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015
sanlock-3.2.4-1.el7    BUILT: Fri Jun 19 12:48:49 CDT 2015
sanlock-lib-3.2.4-1.el7    BUILT: Fri Jun 19 12:48:49 CDT 2015
lvm2-lockd-2.02.130-1.el7    BUILT: Wed Sep  9 02:44:18 CDT 2015


How reproducible:
Everytime

Comment 1 Peter Rajnoha 2015-10-08 12:31:32 UTC
This is resolved already with this patch (lvm 2.02.131):

https://git.fedorahosted.org/cgit/lvm2.git/commit/?id=2ce8ee0214c84a4afd12589bbe2fe521c2518b87

Comment 2 Peter Rajnoha 2015-10-09 07:15:02 UTC
We're in blocker phase now and this bug is not causing harm and it happens only if we do vgcreate together with PV creation in one step. Also, lvmlockd is technical preview in 7.2. Moving this to 7.3.

Comment 5 Mike McCune 2016-03-28 23:39:55 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 7 Corey Marthaler 2016-06-16 21:46:09 UTC
Fix verified in the latest rpms.


3.10.0-418.el7.x86_64
lvm2-2.02.156-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
lvm2-libs-2.02.156-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
lvm2-cluster-2.02.156-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-1.02.126-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-libs-1.02.126-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-event-1.02.126-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-event-libs-1.02.126-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
device-mapper-persistent-data-0.6.2-0.1.rc8.el7    BUILT: Wed May  4 02:56:34 CDT 2016
cmirror-2.02.156-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016
sanlock-3.3.0-1.el7    BUILT: Wed Feb 24 09:52:30 CST 2016
sanlock-lib-3.3.0-1.el7    BUILT: Wed Feb 24 09:52:30 CST 2016
lvm2-lockd-2.02.156-1.el7    BUILT: Mon Jun 13 03:05:51 CDT 2016



[root@mckinley-02 ~]#  vgcreate --shared vg /dev/mapper/mpath[abcdefgh]1
  WARNING: shared lock type "sanlock" and lvmlockd are Technology Preview.
  For more information on Technology Preview features, visit:
  https://access.redhat.com/support/offerings/techpreview/
  Enabling sanlock global lock
  Physical volume "/dev/mapper/mpathc1" successfully created.
  Physical volume "/dev/mapper/mpathg1" successfully created.
  Physical volume "/dev/mapper/mpathh1" successfully created.
  Logical volume "lvmlock" created.
  Volume group "vg" successfully created
  VG vg starting sanlock lockspace
  Starting locking.  Waiting until locks are ready...

Comment 9 errata-xmlrpc 2016-11-04 04:10:31 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-1445.html


Note You need to log in before you can comment on or make changes to this bug.