Bug 1261643 - Upgrading a Satellite system does not keep previous capsule settings
Upgrading a Satellite system does not keep previous capsule settings
Status: CLOSED WORKSFORME
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Upgrades (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Stephen Benjamin
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-09 16:25 EDT by sthirugn@redhat.com
Modified: 2016-02-22 10:47 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-22 10:47:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description sthirugn@redhat.com 2015-09-09 16:25:26 EDT
Description of problem:
I upgraded my Satellite from Sat 6.1.2 Compose 2 to Compose 3.  After upgrade I was not able to provision host using libvirt/NAT

Version-Release number of selected component (if applicable):
Sat 6.1.2 Compose 3

How reproducible:
Always

Steps to Reproduce:
1.Install Sat 6.1.2 Compose 2 ( I believe any older version can be installed)
2.Setup libvirt provisioning and create few hosts - worked fine
3.Upgrade to the latest Compose
4.Attempt to create a new host in the same libvirt setup

Actual results:
- I am not able to create the host. 'New Host' page -> Network tab -> IP address is not suggested
- Also I went to Infrastructure -> Capsules. I saw the features listed as "Puppet, Puppet CA, Discovery, Pulp, and Openscap"

Production.log showed:
2015-09-09 15:00:45 [I]   Parameters: {"subnet_id"=>"1", "host_mac"=>"", "organization_id"=>"17", "location_id"=>"2"}
2015-09-09 15:00:45 [W] Failed to fetch a free IP from our proxy: ERF12-8202 [ProxyAPI::ProxyException]: Unable to retrieve unused IP ([RestClient::ResourceNotFound]: 404 Resource Not Found) for proxy https://$host:9090/dhcp
2015-09-09 15:00:45 [I] Completed 200 OK in 76ms (ActiveRecord: 4.1ms)


Expected results:
Libvirt provisioning should work after upgrade

Additional info:
* I reran the katello-installer again in the same way as I installed it first time.
katello-installer -d -v --capsule-tftp="true" --foreman-admin-password="changeme" --capsule-dhcp-interface="virbr1" --katello-proxy-password="redhat" --capsule-dns-interface="virbr1" --katello-proxy-port="3128" --capsule-tftp-servername=$host --capsule-dns="true" --capsule-register-in-foreman="true" --capsule-puppet="true" --capsule-puppetca="true" --capsule-dns-zone=*** --capsule-dhcp="true" --katello-proxy-url=$url --katello-proxy-username="admin" --capsule-dns-forwarders=$ip --capsule-dns-forwarders=$ip --capsule-dns-forwarders=$ip
* Now it started working. I went to Infrastructure -> Capsules. I saw the features listed as "TFTP, DNS, DHCP, Puppet, Puppet CA, Discovery, Pulp, and Openscap"
Comment 3 Og Maciel 2015-09-09 16:38:32 EDT
So the issue here is that when you upgrade a system via katello-installer --upgrade, whatever features you had enabled for the default capsule (eg. dhcp, dns, pulp, etc) get dropped and once the upgrade is done you end up with less features that you had before (namely dhcp and dns). Could this be because the katello-installer was run with -v -d and if I remember correctly there's no 'answer file' which the installer may look for?
Comment 5 Stephen Benjamin 2016-02-22 10:47:07 EST
1. Configured a capsule with DNS and DHCP settings
2. Ran `katello-installer --upgrade -d -v`
3. Capsule still had DNS and DHCP settings configured

If this was an issue, it doesn't appear to be now.

Note You need to log in before you can comment on or make changes to this bug.