Bug 1261661 - 6Server and 7Server kickstart repos not available
Summary: 6Server and 7Server kickstart repos not available
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: WebUI
Version: 6.1.0
Hardware: All
OS: Linux
unspecified
high vote
Target Milestone: Unspecified
Assignee: Brad Buckingham
QA Contact: Corey Welton
URL: http://projects.theforeman.org/issues...
Whiteboard: Verified in Upstream
Depends On:
Blocks: 1287901
TreeView+ depends on / blocked
 
Reported: 2015-09-09 22:04 UTC by Jacob Hunt
Modified: 2019-10-10 10:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-27 08:55:51 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of available kickstarts (94.87 KB, image/png)
2015-09-09 22:05 UTC, Jacob Hunt
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:1500 normal SHIPPED_LIVE Red Hat Satellite 6.2 Base Libraries 2016-07-27 12:24:38 UTC

Description Jacob Hunt 2015-09-09 22:04:30 UTC
Description of problem:

I would like to keep my installation media up to date but I do not have an option to enable the updated repos for 6Server and 7Server. Instead I have to manually update installation to sync whatever the latest version is (6.7 and 7.1) and then update all my operating systems, host groups, hosts etc.

Workstation kickstart exist for 6Workstation and 7Workstation but I would like to know why server kickstart repos are missing.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Jacob Hunt 2015-09-09 22:05:30 UTC
Created attachment 1071960 [details]
screenshot of available kickstarts

Comment 2 Jacob Hunt 2015-09-09 22:07:34 UTC
From the attached screenshot you can see kickstart repos

RHEL 7 Server 7.0
RHEL 7 Server 7.1

But on the RHEL 7 workstation you see,

RHEL 7 Workstation 7.0
RHEL 7 Workstation 7.1
RHEL 7 Workstation

The "RHEL 7 Server" isn't showing up.

-Jacob

Comment 4 Brad Buckingham 2015-11-19 16:01:32 UTC
The 'Server' (e.g. 6Server) kickstart repositories were purposely omitted.  The  fact that (with the Server repo) the underlying content of the kickstart changes with each new release of the OS (e.g. 6.6 released, 6Server points to 6.6... 6.7 release, 6Server points to 6.7...etc) causes problems for the underlying provisioning and content management.  In addition, it makes it more difficult for the user to control the content that is actually being exposed.  For this reason, 'Server' repositories were omitted and as new releases of the OS come out, the user can enable the new KS repository for that release, sync it and publish/promote it within their content views thereby providing a controlled introduction of the new release.

The fact that the other variants (e.g. Workstation, Client, ComputeNode) were not omitted is a bug and the software will be updated to exclude them as well.

Comment 5 Brad Buckingham 2015-11-19 16:01:48 UTC
Created redmine issue http://projects.theforeman.org/issues/12534 from this bug

Comment 6 Bryan Kearney 2015-11-19 17:01:03 UTC
Upstream bug component is WebUI

Comment 7 Brad Buckingham 2015-11-19 19:04:27 UTC
upstream Katello PR: https://github.com/Katello/katello/pull/5614

Comment 8 Bryan Kearney 2015-11-20 23:01:06 UTC
Moving to POST since upstream bug http://projects.theforeman.org/issues/12534 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|0a254d1733d9041c61be4e69e78bd23646f196df.

Comment 9 Tazim Kolhar 2015-11-23 05:25:02 UTC
VERIFIED:
# rpm -qa | grep foreman
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-proxy-1.0-1.noarch
foreman-release-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-vmware-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-debug-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-libvirt-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-selinux-1.11.0-0.develop.201510071426git6234447.el7.noarch
tfm-rubygem-foreman_hooks-0.3.9-1.el7.noarch
tfm-rubygem-hammer_cli_foreman_tasks-0.0.8-1.el7.noarch
tfm-rubygem-foreman_gutterball-0.0.1-3.el7.noarch
foreman-postgresql-1.11.0-0.develop.201511161350git860ef06.el7.noarch
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-proxy-client-1.0-1.noarch
tfm-rubygem-foreman_discovery-4.1.2-1.fm1_11.el7.noarch
foreman-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-ovirt-1.11.0-0.develop.201511161350git860ef06.el7.noarch
tfm-rubygem-hammer_cli_foreman_bootdisk-0.1.3-3.el7.noarch
foreman-proxy-1.11.0-0.develop.201511161424gitf24be74.el7.noarch
foreman-compute-1.11.0-0.develop.201511161350git860ef06.el7.noarch
tfm-rubygem-hammer_cli_foreman_docker-0.0.3-4.el7.noarch
hp-dl360g7-01.lab.eng.brq.redhat.com-foreman-client-1.0-1.noarch
tfm-rubygem-foreman_bootdisk-6.0.0-2.fm1_10.el7.noarch
tfm-rubygem-hammer_cli_foreman-0.4.0-1.201511111650gitdda13df.el7.noarch
foreman-gce-1.11.0-0.develop.201511161350git860ef06.el7.noarch
foreman-release-scl-1-1.el7.x86_64
tfm-rubygem-foreman_docker-1.4.1-2.fm1_10.el7.noarch
tfm-rubygem-foreman-tasks-0.7.6-1.fm1_10.el7.noarch

steps:
Kickstart repos visible

Comment 13 errata-xmlrpc 2016-07-27 08:55:51 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1500


Note You need to log in before you can comment on or make changes to this bug.