Bug 1261667 - Host operating system field switches on its own
Host operating system field switches on its own
Status: CLOSED DUPLICATE of bug 1155704
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.0
All Linux
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Ohad Levy
Katello QA List
: Triaged
Depends On:
Blocks: 1267521 1287901
  Show dependency treegraph
 
Reported: 2015-09-09 18:34 EDT by Jacob Hunt
Modified: 2017-04-25 12:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-09 11:06:14 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of host field (18.43 KB, image/png)
2015-09-09 18:34 EDT, Jacob Hunt
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 6006 None None None 2016-12-06 08:09 EST

  None (edit)
Description Jacob Hunt 2015-09-09 18:34:36 EDT
Created attachment 1071970 [details]
screenshot of host field

Description of problem:

If a host is created and assigned to a host group (with operating system settings defined) the host os field will randomly switch after what seems to be some puppet runs. We have seen hosts switch from rhel 6.6 workstation to 6.6 server and 7 server to 7 workstation randomly.
It doesn't actually affect the host unless you try to rebuild the host while the OS field is set incorrectly. When the host switches it seems to clean the installation media field and partition table so those fields need to be manually assigned again. The attached picture shows what a host does after being set as 6.6 workstation and then building and running puppet. The host automatically changed to el6s (6.6 server) and the fields were cleared.


Additional info:
Our hosts switch workstation -> server. Looking back at
our hosts it appears that every puppet run workstation builds are switching
to server builds and losing their installation media and partition
information. Server builds are not switching to workstation anymore.
Comment 4 Tomer Brisker 2016-12-06 08:08:56 EST
Connecting redmine issue http://projects.theforeman.org/issues/6006 from this bug
Comment 5 Bryan Kearney 2016-12-06 10:18:19 EST
Upstream bug component is Provisioning
Comment 6 Bryan Kearney 2016-12-09 04:18:18 EST
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/6006 has been resolved.
Comment 7 Brad Buckingham 2016-12-09 11:06:14 EST
I am going to close this as a duplicate of bug 1155704, since they are both tied to the same upstream issue.

*** This bug has been marked as a duplicate of bug 1155704 ***

Note You need to log in before you can comment on or make changes to this bug.