Bug 126169 - services service no longer working
Summary: services service no longer working
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xinetd   
(Show other bugs)
Version: 2
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jay Fenlason
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-17 00:32 UTC by Dax Kelson
Modified: 2014-08-31 23:26 UTC (History)
1 user (show)

Fixed In Version: 2.3.13-4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-26 19:25:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2004-06-17 00:32:54 UTC
Description of problem:

On FC2, the internal Xinetd "services" service no longer works:

[root@station1 root]# chkconfig services on
[root@station1 root]# /etc/init.d/xinetd restart
Stopping xinetd:                                           [  OK  ]
Starting xinetd:                                           [  OK  ]
[root@station1 root]# telnet 127.0.0.1 9098
Trying 127.0.0.1...
telnet: connect to address 127.0.0.1: Connection refused
telnet: Unable to connect to remote host: Connection refused

/var/log/messages has:

Jun 11 20:35:19 station1 xinetd[29290]: No such internal service:
services/stream - DISABLING


On RHEL3/FC1 outputs the following:

# chkconfig services on
# telnet 127.0.0.1 9098
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
finger tcp 79
ntalk udp 518
services tcp 9098
sgi_fam tcp 32769
talk udp 517
telnet tcp 23
Connection closed by foreign host.

Comment 1 Jay Fenlason 2004-06-17 20:48:18 UTC
Looks like upstream removed it from 2.3.12 without mentioning it in 
the changelog, and I never noticed (There's only ~5300 lines of 
diffs between 2.3.12 and 2.3.13).  You might want to ask them why 
(www.xinetd.org).  In the mean time I should remove it from the 
Fedora spec file. 
 
 


Note You need to log in before you can comment on or make changes to this bug.