Bug 126173 - eog cannot display transparent png
Summary: eog cannot display transparent png
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: eog   
(Show other bugs)
Version: 1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL: ftp://coffee.phys.unm.edu/pub/dima/pn...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-17 02:41 UTC by Dmitri A. Sergatskov
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-18 22:20:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample file (transparent png) (6.36 KB, image/png)
2004-06-17 02:43 UTC, Dmitri A. Sergatskov
no flags Details

Description Dmitri A. Sergatskov 2004-06-17 02:41:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
eog cannot display transparent png images. The background is checkered
black/gray. I cannot verify that image is 100% conformant PNG
(it is created by gnuplot 4.0), but mozilla and "display" (from
ImageMagic) display it correctly.   
I suspect this is fault in one of the libraries since
kview and GQview fail as well. 

Version-Release number of selected component (if applicable):
eog 2.4.0

How reproducible:
Always

Steps to Reproduce:
1.Save the image from URL to the disk
2.open it in eog
3.
    

Actual Results:  Background is checkered black/gray.

Expected Results:  Transparent background

Additional info:

Comment 1 Dmitri A. Sergatskov 2004-06-17 02:43:29 UTC
Created attachment 101204 [details]
Sample file (transparent png)

Comment 2 Peter van Egdom 2004-06-18 21:16:14 UTC
This is not a bug, but a feature. Both "eog" (and, for example, the
Gimp) use the checkered black/grey background to display the
transparant part of the picture. In "eog" you can use the preferences
screen to specify what to do with the transparant part of the picture.


Note You need to log in before you can comment on or make changes to this bug.