Bug 1261741 - Tier: glusterd crash when trying to detach , when hot tier is having exactly one brick and cold tier is of replica type
Tier: glusterd crash when trying to detach , when hot tier is having exactly ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Triaged
Depends On:
Blocks: 1260923 1261742
  Show dependency treegraph
 
Reported: 2015-09-10 02:03 EDT by Mohammed Rafi KC
Modified: 2016-06-16 09:36 EDT (History)
3 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1261742 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:36:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-09-10 02:03:44 EDT
Description of problem:
glusterd crash when trying to detach , when hot tier is having exactly one brick and cold tier with two bricks. This because of wrong calculation of subvols.


Version-Release number of selected component (if applicable):

mainline

How reproducible:

100%

Steps to Reproduce:
1.create a replica 2 volume with two bricks
2.attach a tier with one brick
3.detach the tier

Actual results:

crash

Expected results:

detach should success.

Additional info:
Comment 1 Vijay Bellur 2015-09-10 02:04:29 EDT
REVIEW: http://review.gluster.org/12145 (tier/glusterd : Disable subvol match check during detach tier) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-09-12 09:23:09 EDT
REVIEW: http://review.gluster.org/12145 (tier/glusterd : Disable subvol match check during detach tier) posted (#3) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Vijay Bellur 2015-09-14 05:05:28 EDT
COMMIT: http://review.gluster.org/12145 committed in master by Atin Mukherjee (amukherj@redhat.com) 
------
commit 2e041639d8e49e2b768dd43c6f702106250e4da9
Author: Mohammed Rafi KC <rkavunga@redhat.com>
Date:   Thu Sep 10 11:27:42 2015 +0530

    tier/glusterd : Disable subvol match check during detach tier
    
    For tiering, user does not have authorization to choose
    for bricks to detach, so we don't need to whether subvols
    match for the bricks or not.
    
    Change-Id: I7e777ccc1aa261f652f9b158718fcd55185c7794
    BUG: 1261741
    Signed-off-by: Mohammed Rafi KC <rkavunga@redhat.com>
    Reviewed-on: http://review.gluster.org/12145
    Reviewed-by: Dan Lambright <dlambrig@redhat.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>
Comment 4 Niels de Vos 2016-06-16 09:36:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.