Bug 1261760 - perl-MooseX-App-Cmd-0.31-3.fc24 FTBFS: Failed test 'Internal hashes match'
perl-MooseX-App-Cmd-0.31-3.fc24 FTBFS: Failed test 'Internal hashes match'
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-MooseX-App-Cmd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Emmanuel Seyman
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 02:37 EDT by Petr Pisar
Modified: 2015-09-13 06:25 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-MooseX-App-Cmd-0.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-13 06:25:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 107025 None None None Never

  None (edit)
Description Petr Pisar 2015-09-10 02:37:57 EDT
perl-MooseX-App-Cmd-0.31-3.fc24 fails to build in F24 because a test fails:

t/basic.t ............... ok
#   Failed test 'Internal hashes match'
#   at t/build_emulates_new.t line 16.
#     Structures begin differing at:
#          $got->{show_version} = Does not exist
#     $expected->{show_version} = '0'
# Looks like you failed 1 test of 1.
t/build_emulates_new.t .. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 

This has been happening since upgrading perl-App-Cmd from 0.327-3.fc23 to 0.328-1.fc24.
Comment 1 Emmanuel Seyman 2015-09-13 06:25:33 EDT
I've updated perl-MooseX-App-Cmd to 0.32 in rawhide. The changelog reads:

0.32      2015-09-12 01:10:11Z
    - fix incompatibility with App::Cmd 0.328 by calling its
      constructor (via MooseX::NonMoose) (RT#107025)

and rt #107025 describes this very problem.

Note You need to log in before you can comment on or make changes to this bug.