Bug 1261766 - RFE: way to force no metadata expiration system-wide
Summary: RFE: way to force no metadata expiration system-wide
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-10 06:49 UTC by Michael S. Tsirkin
Modified: 2015-10-05 21:53 UTC (History)
7 users (show)

Fixed In Version: dnf-1.1.2-4.fc23 dnf-1.1.2-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 19:13:44 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michael S. Tsirkin 2015-09-10 06:49:48 UTC
Description of problem:
I set 
metadata_expire=never
in /etc/dnf/dnf.conf

I then expect dnf to always use a cache e.g. when
I do dnf search.
but this does not prevent dnf from re-downloading
metadata every couple of days.

Version-Release number of selected component (if applicable):
dnf-1.1.0-2.fc22.noarch

How reproducible:
every couple of days

Steps to Reproduce:
1. set metadata_expire=never
2. dnf search <some package> every couple of days

Actual results:
dnf goes on the network and downloads something
from Fedora repo displaying progress bar (I'm not sure it's metadata, but what
else is needed for search command?)

Expected results:
No network activity as long as metadata is not manually cleaned
or new repo isn't added.

Additional info:

Comment 1 Michael S. Tsirkin 2015-09-10 06:58:12 UTC
I think I see the issue.
Individual repo files override metadata_expire.

I think there needs to be a way to force no meta data
expiration system wide without editing each repo file.

Changed BZ title to RFE accordingly.

Documentation for dnf.conf should probably mention that
repo conf takes precedence over the global config
and not the other way around.

Comment 2 Michal Luscon 2015-09-10 09:45:02 UTC
The documentation of dnf already mentions that fact - http://dnf.readthedocs.org/en/latest/conf_ref.html#options-for-both-main-and-repo .

Comment 3 Michael S. Tsirkin 2015-09-10 10:49:40 UTC
but man dnf doesn't.
it just says
      DNF  by  default uses the global configuration file at /etc/dnf/dnf.conf
and all *.repo files found under /etc/yum.repos.d. The latter
       is typically used for repository configuration.

Comment 4 Michael S. Tsirkin 2015-09-10 10:49:59 UTC
man dnf.conf of course

Comment 5 Radek Holy 2015-09-10 16:43:31 UTC
Actually since both the man pages and the web page are built from the same source, both say (almost) the same:

man dnf.conf | grep -C 2 'concrete'
       Some options can be applied in either the main section, per repository,
       or in a combination. The value provided in the main section is used for
       all repositories as the default value  and  concrete  repositories  can
       override it in their configuration.

Comment 6 Fedora Update System 2015-09-22 15:00:54 UTC
hawkey-0.6.1-1.fc23 dnf-plugins-core-0.1.12-2.fc23 dnf-1.1.2-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16428

Comment 7 Fedora Update System 2015-09-22 15:02:59 UTC
dnf-plugins-core-0.1.12-2.fc22 hawkey-0.6.1-1.fc22 dnf-1.1.2-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-16429

Comment 8 Fedora Update System 2015-09-23 03:54:36 UTC
dnf-1.1.2-2.fc23, dnf-plugins-core-0.1.12-2.fc23, hawkey-0.6.1-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf-plugins-core dnf hawkey'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16428

Comment 9 Fedora Update System 2015-09-23 21:22:27 UTC
dnf-1.1.2-2.fc22, dnf-plugins-core-0.1.12-2.fc22, hawkey-0.6.1-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update dnf-plugins-core dnf hawkey'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-16429

Comment 10 Fedora Update System 2015-10-02 15:20:27 UTC
dnf-plugins-core-0.1.12-3.fc23 hawkey-0.6.1-2.fc23 dnf-1.1.2-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-38e69423f3

Comment 11 Fedora Update System 2015-10-02 15:24:32 UTC
dnf-plugins-core-0.1.12-3.fc22 hawkey-0.6.1-2.fc22 dnf-1.1.2-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3528c659e4

Comment 12 Fedora Update System 2015-10-04 01:36:07 UTC
dnf-1.1.2-4.fc22, dnf-plugins-core-0.1.12-3.fc22, hawkey-0.6.1-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update hawkey dnf-plugins-core dnf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3528c659e4

Comment 13 Fedora Update System 2015-10-04 01:52:00 UTC
dnf-1.1.2-4.fc23, dnf-plugins-core-0.1.12-3.fc23, hawkey-0.6.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update hawkey dnf-plugins-core dnf'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-38e69423f3

Comment 14 Fedora Update System 2015-10-04 19:12:51 UTC
dnf-1.1.2-4.fc23, dnf-plugins-core-0.1.12-3.fc23, hawkey-0.6.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-10-05 21:52:21 UTC
dnf-1.1.2-4.fc22, dnf-plugins-core-0.1.12-3.fc22, hawkey-0.6.1-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.