Bug 126178 - Boot loader configuration impossible
Boot loader configuration impossible
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 02:46 EDT by Quent
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-17 13:56:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quent 2004-06-17 02:46:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031030

Description of problem:
Description of Problem: Anaconda doesn't want to create a loader
configuration in upgrade mode

The problem is possibly from anaconda boot loader install
but grub doesn't seem to be functional either (due to anaconda
install, skipping boot loader part)

I have installed Fedora Core 2 on /dev/hda3 with anaconda (winXP
already installed on /dev/sda1)
Not sure about boot configuration, I have decided to skip it, to do it
later (didn't want to override MBR...) I installed all the rest of
Core 2 without any problems.

I tried to perform a manual grub install via "linux rescue" boot mode,
typing "grub-install /dev/hda3" but:
-I got 
"Installation finish. No error reported
"This is device.map
"(fd0) /dev/fd0
"(hd0) /dev/hda
"Check it, fix it and re-run"
(So I also tried by adding the line "(hd0,3) /dev/hda3" but it didn't
like the coma apparently)
-I didn't find any grub.conf in /etc/ nor in /boot/grub/ (I performed
chroot /mnt/sysimage) nor menu.lst in /boot/grub/ (just .img and XXX
in /boot/ and XXX in /boot/grub)
=>grub-install didn't work

So I tried to reboot in install mode and used upgrade mode to perform
anaconda's boot loader config (cf. below...)


Version-Release number of selected component (if applicable):
don't know

How reproducible:
Always

Steps to Reproduce:
1. Install Fedora 2 + skip Boot loader configuration on /dev/hda3
2. Reboot on CD1 install, use 'linux rescue' mode
3. Run 'grub-install /dev/hda3' -> nothing done (cf. description above)
4. Reboot on CD1 install
5. Choose upgrade existing install Fedora 2 on /dev/hda3
6. Choose Create new Boot loader configuration (update boot config is
unavailable)
7. Step forward GRUB Boot loader installation with "configure advanced
boot loader options"
8. Select boot loader record on /dev/hda3
9. Go

Actual Results:  (Transferring install image to hard drive
Installation of a few packages aspell?, compat-db, post-install)

Then: Message: "No kernel packages were installed on your system, 
Your boot loader configuration will not be changed" OK, Reboot...


Expected Results:  Installation of boot loader successful...

Additional info:

I also posted a submission for the grub-install part.

Reproducibility:
I only installed FC2 skipping boot loader config
But: grub-install and anaconda upgrade are always reproducible
Comment 1 Jeremy Katz 2004-06-17 13:56:43 EDT
We cannot sanely create a boot loader configuration unless we're
installing a kernel.  The upgrade scenario you created didn't install
a kernel and thus a boot loader config can't be created.  

If you choose to skip doing boot loader configuration, then, yes,
you're going to need to do it all by hand after the fact.
Comment 2 Quent 2004-06-17 20:31:05 EDT
But so, shouldn't it be said during the install (1st one, not the
upgrade):
"Warning if you skip that skip you'll have to install loader yourself
(not using anaconda)"
(Unless there's a way to also reinstall kernel via anaconda upgrade
but I was not prompted for) ?

Thanks anyway, Quentin

Note You need to log in before you can comment on or make changes to this bug.