Bug 126179 - Does not render correctly with indic scripts + english
Summary: Does not render correctly with indic scripts + english
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkhtml3   
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Dave Malcolm
QA Contact:
URL:
Whiteboard:
Keywords: i18n
Depends On:
Blocks: Indic
TreeView+ depends on / blocked
 
Reported: 2004-06-17 06:52 UTC by Leon Ho
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-23 12:22:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
problem screenshot (62.61 KB, image/png)
2004-06-17 06:53 UTC, Leon Ho
no flags Details
problem screenshot - highlight is fine (62.87 KB, image/png)
2004-06-17 06:54 UTC, Leon Ho
no flags Details
New compose test (78.90 KB, image/png)
2004-09-17 06:08 UTC, Jatin Nansi
no flags Details

Description Leon Ho 2004-06-17 06:52:43 UTC
Description of problem:
When indic scripts entered followed by english letters, the english
letters will render incorrect to indic as well.

Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. LANG=hi_IN.UTF-8 evolution
2. New mail
3. Cut and paste a hindi char, then follow by "abcde" (no input method
involved)
  
Actual results:
"abcde" changed to indic glyphs

Expected results:
should be "abcde" glyphs shown onto the screen

Additional info:
Highlight abcde shows correct glyphs again

Comment 1 Leon Ho 2004-06-17 06:53:50 UTC
Created attachment 101208 [details]
problem screenshot

Comment 2 Leon Ho 2004-06-17 06:54:19 UTC
Created attachment 101209 [details]
problem screenshot - highlight is fine

Comment 3 Leon Ho 2004-07-13 03:22:15 UTC
I have debugged for a while and found out because when it itemize and
shape, it returns a GList of PangoGlyphString (glyphs) and Glist of
PangoItem (items) to draw_text()

Because the nature of Indic scripts that several characters can be
represent as a glyph, so the PangoItem and PangoGlyphString does not
align together.

PangoItem        [1] [2] [3] [4] [5]
PangoGlyphString [1]         [2] [3]

But gtkhtml still access PangoItem one by one (There aren't any ways
to know how many chars the glyph represent) hence the attribute used
in indic glyph are used on english glyph.

Comment 5 Leon Ho 2004-07-13 03:39:46 UTC
sorry should be this one:
http://bugzilla.ximian.com/show_bug.cgi?id=61462

Comment 6 Jatin Nansi 2004-09-17 06:08:29 UTC
Created attachment 103942 [details]
New compose test

Comment 7 Jatin Nansi 2004-09-17 06:11:46 UTC
I recommend we close this bug, since hindi + english works fine now as
per the screenshot attached above.
This is with evolution 1.5.94.1-1 and gtkhtml3-3.3.0-3 on RHEL4 B1
from 16.09.04.

Comment 8 Leon Ho 2004-09-23 12:22:09 UTC
Double that. It is looking fine. Closing this bug for now.


Note You need to log in before you can comment on or make changes to this bug.