Bug 1261790 - xml created by 'virsh dumpxml <domain>' does not validate with 'virt-xml-validate' command, when the domain's interface type is "network"
xml created by 'virsh dumpxml <domain>' does not validate with 'virt-xml-vali...
Status: CLOSED DUPLICATE of bug 1177594
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt (Show other bugs)
x86_64 Unspecified
low Severity medium
: rc
: ---
Assigned To: Libvirt Maintainers
Virtualization Bugs
Depends On:
  Show dependency treegraph
Reported: 2015-09-10 03:31 EDT by yafu
Modified: 2015-09-10 04:29 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-09-10 04:29:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description yafu 2015-09-10 03:31:35 EDT
Description of problem:
xml created by 'virsh dumpxml <domain>' does not validate with 'virt-xml-validate',when the domain's interface type is 'network'.
And when the domain's interface type is 'bridge',dumpxml can validate with 'virt-xml-validate'.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.cat lxc.xml:
<domain type='lxc' id='3211'>
  <memory unit='KiB'>1048576</memory>
  <currentMemory unit='KiB'>1048576</currentMemory>
  <vcpu placement='static'>1</vcpu>
    <type arch='x86_64'>exe</type>
  <clock offset='utc'/>
    <filesystem type='mount' accessmode='passthrough'>
      <source dir='/'/>
      <target dir='/'/>
    <interface type='network'>
      <mac address='00:16:3e:54:f2:8c'/>
      <source network='default'/>
      <target dev='vnet0'/>
    <console type='pty' tty='/dev/pts/1'>
      <source path='/dev/pts/1'/>
      <target type='lxc' port='0'/>
      <alias name='console0'/>
  <seclabel type='none' model='selinux'/>

2. virsh -c lxc:/// define lxc.xml
3. virsh -c lxc:/// start lxc1
4. virsh -c lxc:/// dumpxml lxc1 > /tmp/a.xml
5. virt-xml-validate /tmp/a.xml

It's a regression bug,but not very serious.
Comment 2 yafu 2015-09-10 04:11:35 EDT
The same result also appears in the qemu-kvm,when the domain's interface type is 'network'.
Comment 3 Ján Tomko 2015-09-10 04:29:55 EDT

*** This bug has been marked as a duplicate of bug 1177594 ***

Note You need to log in before you can comment on or make changes to this bug.