Bug 1261798 - "shadow" files overwritten with old RHEL-6 versions
"shadow" files overwritten with old RHEL-6 versions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant-contents (Show other bugs)
6.7
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: pstodulk
Marian Ganisin
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 03:44 EDT by Marian Ganisin
Modified: 2015-11-19 18:33 EST (History)
6 users (show)

See Also:
Fixed In Version: preupgrade-assistant-contents-0.6.37-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:33:21 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Ganisin 2015-09-10 03:44:41 EDT
Description of problem:

some postupgrade script from contents seems to rewrite /etc/passwd & co. files with old versions from RHEL-6

This causes loss of all new users & groups or modifications made during upgrade transaction.

Version-Release number of selected component (if applicable):
preupgrade-assistant-contents-0.6.36-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. do the upgrade
2. on upgraded RHEL-7 check /etc/group & /etc/group.preupg
3. *.preupg file contains new content that is missing in regular file


Additional info:
This breaks features where RHEL-7 services on new groups. One example can be ssh server keys stored in /etc/ssh. New generated keys (that weren't available in RHEL-6) have wrong group ownership.
Comment 3 Marian Ganisin 2015-10-14 05:52:42 EDT
cleanconf dir does not contain "shadow" files (passwd,group,shadow,gshadow).
Upgraded RHEL-7 system seems to have correct files with all the new records included.
No .preupg copy of "shadow" files present in /etc.
Issue seems to be fixed properly.
Comment 6 errata-xmlrpc 2015-11-19 18:33:21 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2498.html

Note You need to log in before you can comment on or make changes to this bug.