Bug 1261802 - [RFE] Make the foreman bootdisk full-host image work on UEFI systems
Summary: [RFE] Make the foreman bootdisk full-host image work on UEFI systems
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Bootdisk Plugin
Version: 6.1.1
Hardware: x86_64
OS: Linux
high
high vote
Target Milestone: Unspecified
Assignee: Lukas Zapletal
QA Contact:
URL: http://projects.theforeman.org/issues...
Whiteboard:
: 1133697 (view as bug list)
Depends On: 1401491
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-10 08:07 UTC by David Juran
Modified: 2019-08-12 16:05 UTC (History)
14 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 19:12:55 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Foreman Issue Tracker 4413 None None None 2016-07-21 09:03:43 UTC
Red Hat Knowledge Base (Solution) 1133697 None None None 2018-12-06 17:51:59 UTC

Description David Juran 2015-09-10 08:07:07 UTC
Description of problem:
The foreman full-host bootdisk does today not work on UEFI-only systems like microsoft HyperV gen 2

Version-Release number of selected component (if applicable):
ruby193-rubygem-foreman_bootdisk-4.0.2.13



Additional info:
Possibly as simple as adding the '--uefi' flag to call to "isohybrid" in iso_generator.rb, but this is purely a speculation.

Comment 6 Lukas Zapletal 2016-07-14 12:18:50 UTC
Please note PXE-less ISO image is compatible with UEFI, so it can be used as a workaround. It's present in 6.1+

https://access.redhat.com/blogs/1169563/posts/2090011

Comment 10 Lukas Zapletal 2016-07-21 08:51:05 UTC
*** Bug 1133697 has been marked as a duplicate of this bug. ***

Comment 24 Lukas Zapletal 2016-11-09 15:33:18 UTC
Upstream patch is at https://github.com/theforeman/foreman_bootdisk/pull/33

Comment 26 Lukas Zapletal 2016-12-05 12:38:40 UTC
Hello, I have evaluated the options, created initial version for Full host image (see comment 24) but for other image types, we need some changes in the iPXE firmware. I filed new BZ for this for our booloader team: https://bugzilla.redhat.com/show_bug.cgi?id=1401491

Comment 27 Edu Alcaniz 2017-03-07 11:24:01 UTC
Hi, could I have an update about this BZ?

Comment 28 Lukas Zapletal 2017-03-07 12:52:11 UTC
Yes, we are missing Satellite 6.3 with this one for sure, it's complicated case, we are working with platform to make some changes in iPXE project and still prototyping and testing.

Comment 31 Daniel Forsberg 2018-06-21 10:48:43 UTC
New upstream patch for Satellite 6.3 is at https://github.com/theforeman/foreman_bootdisk/pull/64

Comment 32 Bryan Kearney 2018-09-04 19:00:44 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.

Comment 33 Bryan Kearney 2018-09-04 19:12:55 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.