Bug 126182 - Menu does not update until next login
Menu does not update until next login
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gamin (Show other bugs)
rawhide
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Daniel Veillard
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 04:02 EDT by Ivan Gyurdiev
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 08:03:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ivan Gyurdiev 2004-06-17 04:02:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
The menu items do not update until I log into gnome again after
installing new apps. This seems extremely undesirable to me.

Consider Windows. Installing a new application does 1000 different
things to inform you it's been installed - startup menu, tray icon,
desktop icon. I find all that very annoying, but at least I know a new
application has been installed, and I know how to launch it.

Consider Linux. I install a new RPM, and I get no indication of any
kind the application has been installed. It's not even in the menu
intil I log in again. Some might consider this the equivalent of
"reboot to make things work".

Hence -> this bug.


Version-Release number of selected component (if applicable):
gnome-panel-2.6.0-9

How reproducible:
Always

Steps to Reproduce:
1. Install new RPMS.
2. Look at menu.



    

Additional info:
Comment 1 Bill Nottingham 2004-08-05 17:28:15 EDT
This is probably due to the fam-ectomy. Does this work with the new
gamin daemon?
Comment 2 Ivan Gyurdiev 2004-08-06 08:07:59 EDT
Yes, it works now, after I installed gamin.
The bug, therefore, is that the gnome-panel package should require
gamin for proper operation.

 
Comment 3 Mark McLoughlin 2004-08-06 14:31:00 EDT
Moving to gamin - sounds like something got screwed up with the fam ->
gamin update
Comment 4 Daniel Veillard 2004-08-24 08:03:50 EDT
Following Ivan report, it seems to me that gamin 0.0.6 actually fixes
the problem, so this should be resolved in Rawhide unless I 
misunderstood something,

Daniel

Note You need to log in before you can comment on or make changes to this bug.