Bug 126185 - Installer hangs if USB cable modem is connected to computer
Installer hangs if USB cable modem is connected to computer
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-17 04:46 EDT by Tim Camp
Modified: 2015-01-04 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 01:02:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Camp 2004-06-17 04:46:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
When installing Fedora core 2 as a fresh install, I found that 
anaconda hung at the /sbin/loader command when my USB cable modem was 
connected to the PC. When I disconnected the USB modem and 
reinstalled, there was no problem. I did this several times (whilst 
trying to solve an unrelated disk access problem) and found it to be 
repeatable.

Having installed Fedora core 2, if I boot up with the modem 
connected, the boot process hangs during the "search for new 
hardware" phase. To continue, I have to disconnect the modem and 
reboot.

I previously had Red Hat 9 installed, and this worked fine with my 
USB cable modem.

Version-Release number of selected component (if applicable):
Fedora core 2

How reproducible:
Always

Steps to Reproduce:
1. connect cable modem by USB
2. try and install Fedora core 2
3.
    

Actual Results:  Installation hangs at /sbin/loader command

Expected Results:  Installation should continue

Additional info:
Comment 1 Jean-Francois Ramier 2004-07-05 11:05:14 EDT
I have the exact same problem.
Any news since opening the bug?
Any work around?
Comment 2 Tim Camp 2004-07-05 11:11:59 EDT
I think this is a problem with the handling of USB devices. I 
personally got round the problem by connecting my modem to the 
computer using a network interface card instead. Not a real solution, 
but NIC cards are cheaper than grey hairs!
Comment 3 Jean-Francois Ramier 2004-07-05 11:21:13 EDT
I was abled to do the same thing but I am using my network card for a 
home network and can not live the modem an do not have a free slot 
for an additionnal card. So if I andersand write boot without the 
modem open an them I have to remove it an reinstall for it to work?
Comment 4 Tim Camp 2004-07-05 11:30:44 EDT
I wasn't able to use my cable modem at all with a USB connection 
under Fedora. I could install Fedora if the modem was disconnected, 
but could not subsequently boot-up if the modem was connected. I was 
able to use the USB modem with the last Red Hat release however.

To get a solution, I think that someone familiar with the way that 
Fedora handles USB devices needs to take a look. Sorry I'm not much 
help.
Comment 5 Jean-Francois Ramier 2004-07-05 11:50:17 EDT
Thanks 
Comment 6 Jean-Francois Ramier 2004-07-13 01:21:43 EDT
I have found that leaving the modem close while booting so that new
hardware detection does not update anything, an then starting the
modem after sign on, avery thing work fine. Is the problem with Kudzu?
I have tried this with 2 kernel version 2.6.6-1.435.2.3 and
2.6.7-1.459 with the same result.
Comment 7 Jean-Francois Ramier 2004-07-16 19:34:31 EDT
This does not work every time. Sometime the usb server works some time
it does not ??
Comment 8 Dave Jones 2005-04-16 01:02:51 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.