Bug 1261852 - spacewalk-dobby should be (un-)installed in DB migration scenarios
spacewalk-dobby should be (un-)installed in DB migration scenarios
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Docs Installation Guide (Show other bugs)
570
Unspecified Unspecified
high Severity low
: ---
: ---
Assigned To: Russell Dickenson
Julie
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 06:20 EDT by Jan Hutař
Modified: 2017-08-18 05:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-18 05:10:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2015-09-10 06:20:15 EDT
Description of problem:
Package spacewalk-dobby (which contains db-control utility) should be (un-)installed in DB migration scenarios. That tool is supposed to be present only on embedded DB options.


Version-Release number of selected component (if applicable):
current on the web


Expected results:
IMO all (?) these sections will need step with installing/uninstalling spacewalk-dobby package:

  12.8.1. Migrating from an Embedded Database to a Managed Database
  12.8.2. Migrating from an Embedded Database to an External PostgreSQL Database
  12.8.3. Migrating from an Embedded Database to an External Oracle Database
  12.8.4. Migrating from a Managed Database to an Embedded Database
  12.8.5. Migrating from an External PostgreSQL Database to an Embedded Database
  12.8.6. Migrating from an External Oracle Database to an Embedded Database

For example here:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/5.7/html/Installation_Guide/sect-Migrating_from_an_External_Oracle_Database_to_an_Embedded_Database.html

there should be step "yum install -y spacewalk-dobby". I have done this after whole process when testing this and `db-control` seems to be working now. IMO it should be OK to add it to step 7 where we are installing all the required packages.

And for example in:

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/5.7/html/Installation_Guide/sect-Migrating_from_an_Embedded_Database_to_an_External_PostgreSQL_Database.html

new step should be created which would have `yum remove -y spacewalk-dobby`.
Comment 1 Jan Hutař 2015-09-10 06:21:55 EDT
Hello Jan. Could you please "ACK" this request? Also once this is done, whole procedure (all of them) might need some QA check.
Comment 2 Jan Dobes 2015-09-10 11:57:09 EDT
I agree, step with spacewalk-dobby package makes sense. db-control is supported for Embeddded and Managed DB. In each scenario we are working with Embedded DB, even if migrating from/to Managed DB we need to install/uninstall on Satellite system.
Comment 6 Andrew Dahms 2017-07-04 07:44:21 EDT
Moving to 'NEW' and the default assignee to be triaged as the schedule allows.
Comment 8 Julie 2017-07-27 00:45:49 EDT
Merged the request and moving this bug to verified.

Cheers,
Julie
Comment 9 Russell Dickenson 2017-07-27 18:17:56 EDT
The amended Satellite 5.8 Installation Guide has been republished to the Customer Portal [1].

I will request the Satellite 5.7 Installation Guide also be republished.


[1] https://access.redhat.com/documentation/en-us/red_hat_satellite/5.8/html-single/installation_guide/#sect-Migrating_from_a_Managed_Database_to_an_Embedded_Database
Comment 11 Andrew Dahms 2017-08-18 05:10:22 EDT
Hi Russell,

Thank you for the needinfo request, and my apologies for not seeing it sooner.

These changes have now been published, so I am cancelling the needinfo request and moving the bug to CLOSED.

Kind regards,

Andrew

Note You need to log in before you can comment on or make changes to this bug.