Bug 1261860 - label is not added to build-pod when new-app with '-l'
label is not added to build-pod when new-app with '-l'
Status: CLOSED WONTFIX
Product: OpenShift Origin
Classification: Red Hat
Component: Build (Show other bugs)
3.x
Unspecified Unspecified
medium Severity low
: ---
: 3.x
Assigned To: Slava Semushin
Wenjing Zheng
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 06:41 EDT by wyue
Modified: 2015-11-05 21:48 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-07 07:44:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description wyue 2015-09-10 06:41:00 EDT
Description of problem:
label 'test=123' is not added to build-pod 'ruby-sample-build-1-build' when I new app with below command:
oc new-app application-template-stibuild.json -l test=123

How reproducible:
always

Steps to Reproduce:
1.oc new-app application-template-stibuild.json -l test=123
2.after build is completed, check if build-pods have been added labels:
oc get pods -l test=123

Actual results:
no pod is listed

Expected results:
ruby-sample-build-1-build should be listed
Comment 2 Cesar Wong 2015-09-28 13:36:08 EDT
Fabiano, looks like you fixed this one with https://github.com/openshift/origin/pull/4543
Comment 3 wyue 2015-09-29 02:44:47 EDT
Hi, This issue can still reproduce on devenv-fedora_2417

[root@dhcp-128-16 sample-app]# oc get pods
NAME                        READY     STATUS       RESTARTS   AGE
database-1-2mvzt            1/1       Running      0          33m
frontend-1-fnivq            1/1       Running      0          31m
frontend-1-ophw7            1/1       Running      0          31m
ruby-sample-build-1-build   0/1       ExitCode:0   0          33m

[root@dhcp-128-16 sample-app]# oc describe pods ruby-sample-build-1-build
Name:				ruby-sample-build-1-build
Namespace:			test
Image(s):			openshift/origin-sti-builder:v1.0.6
Node:				ip-172-18-7-120/172.18.7.120
Labels:				openshift.io/build.name=ruby-sample-build-1
Status:				Succeeded
Reason:				
Message:			
IP:				
Replication Controllers:	<none>
Containers:
Comment 4 Slava Semushin 2015-10-07 04:49:51 EDT
I've created PR to fix this issue: https://github.com/openshift/origin/pull/4983
Comment 5 Slava Semushin 2015-10-07 07:43:56 EDT
It turned out that it works as expected and this behavior was added intentionally.

See the following links for more details: https://github.com/openshift/origin/issues/3502 and https://github.com/openshift/origin/pull/3508

Note You need to log in before you can comment on or make changes to this bug.