Bug 1261862 - Data Tiering: detach-tier start force command not available on a tier volume(unlike which is possible in force remove-brick)
Data Tiering: detach-tier start force command not available on a tier volum...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Mohammed Rafi KC
bugs@gluster.org
: Triaged
Depends On: 1258242 1271724
Blocks: 1260923
  Show dependency treegraph
 
Reported: 2015-09-10 06:43 EDT by Mohammed Rafi KC
Modified: 2016-06-16 09:36 EDT (History)
5 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1258242
Environment:
Last Closed: 2016-06-16 09:36:20 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mohammed Rafi KC 2015-09-10 06:43:19 EDT
+++ This bug was initially created as a clone of Bug #1258242 +++

Description of problem:
======================
There is no detach-tier start force command available, eventhough it shows in the help.
For eg, offline a tier volume and then issue a detach-tier. It fails saying below:
root@nag-manual-node1 ~]# gluster v detach-tier testme start
volume detach-tier start: failed: Volume testme needs to be started before remove-brick (you can use 'force' or 'commit' to override this behavior)


but,When we try to do a force detach-tier start on an offline volume, it doesnt succeed.It still throws same error:
[root@nag-manual-node1 ~]# gluster v detach-tier testme start force
volume detach-tier start: failed: Volume testme needs to be started before remove-brick (you can use 'force' or 'commit' to override this behavior)

Given that this part of code is taken from remove-brick.
On a regular volume when we do a force remove-brick start, it does start the remove-brick process

hence there is difference in behavior here.



Remove-brick on an offline regular vol:
==============================
Volume Name: test2
Type: Distribute
Volume ID: 7357f734-6ba3-4f9a-b707-8b1defc82459
Status: Created
Number of Bricks: 2
Transport-type: tcp
Bricks:
Brick1: 10.70.47.29:/rhs/brick1/test2
Brick2: 10.70.47.29:/rhs/brick2/test2
Options Reconfigured:
performance.readdir-ahead: on
[root@localhost ~]# gluster  v stop hello
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) n
[root@localhost ~]# gluster v stop test2
Stopping volume will make its data inaccessible. Do you want to continue? (y/n) y
volume stop: test2: failed: Volume test2 is not in the started state

[root@localhost ~]# gluster v remove-brick test2 10.70.47.29:/rhs/brick1/test2 start
volume remove-brick start: failed: Volume test2 needs to be started before remove-brick (you can use 'force' or 'commit' to override this behavior)
[root@localhost ~]# gluster v remove-brick test2 10.70.47.29:/rhs/brick1/test2 start force
wrong brick type: start, use <HOSTNAME>:<export-dir-abs-path>
Usage: volume remove-brick <VOLNAME> [replica <COUNT>] <BRICK> ... <start|stop|status|commit|force>
[root@localhost ~]# gluster v remove-brick test2 10.70.47.29:/rhs/brick1/test2 force
Removing brick(s) can result in data loss. Do you want to Continue? (y/n) y
volume remove-brick commit force: success


Detach-tier on an offline volume
==============================
[root@nag-manual-node1 ~]# gluster v detach-tier testme start
volume detach-tier start: failed: Volume testme needs to be started before remove-brick (you can use 'force' or 'commit' to override this behavior)
[root@nag-manual-node1 ~]# gluster v detach-tier testme start force
volume detach-tier start: failed: Volume testme needs to be started before remove-brick (you can use 'force' or 'commit' to override this behavior)
[root@nag-manual-node1 ~]# 
[root@nag-manual-node1 ~]# 



Version-Release number of selected component (if applicable):
==========================================================
[root@nag-manual-node1 ~]# gluster --version
glusterfs 3.7.3 built on Aug 27 2015 01:23:05
Repository revision: git://git.gluster.com/glusterfs.git
Copyright (c) 2006-2011 Gluster Inc. <http://www.gluster.com>
GlusterFS comes with ABSOLUTELY NO WARRANTY.
You may redistribute copies of GlusterFS under the terms of the GNU General Public License.
[root@nag-manual-node1 ~]# rpm -qa|grep gluster
glusterfs-libs-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-fuse-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-server-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-api-3.7.3-0.82.git6c4096f.el6.x86_64
glusterfs-cli-3.7.3-0.82.git6c4096f.el6.x86_64
python-gluster-3.7.3-0.82.git6c4096f.el6.noarch



How reproducible:


Steps to Reproduce:
1.offline a tier volume
2.issue a detach-tier start
3.it will fail saying use force or commit
4. try using force, it will still throw same error thrown in step#2
Comment 1 Vijay Bellur 2015-09-10 06:44:54 EDT
REVIEW: http://review.gluster.org/12151 (Tier/cli: Change detach-tier commit force to detach-tier force) posted (#1) for review on master by mohammed rafi  kc (rkavunga@redhat.com)
Comment 2 Vijay Bellur 2015-09-12 10:23:47 EDT
REVIEW: http://review.gluster.org/12151 (Tier/cli: Change detach-tier commit force to detach-tier force) posted (#2) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 3 Niels de Vos 2016-06-16 09:36:20 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.