Bug 1261867 - SAHARA - Error creating cluster using use_floating_ips=True
SAHARA - Error creating cluster using use_floating_ips=True
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-sahara (Show other bugs)
7.0 (Kilo)
x86_64 Linux
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Elise Gafford
Luigi Toscano
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 06:47 EDT by Edu Alcaniz
Modified: 2015-09-10 07:36 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-10 07:36:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edu Alcaniz 2015-09-10 06:47:26 EDT
Description of problem:
Error creating cluster 
[root@sahara ~(keystone_admin)]# sahara cluster-create --json /root/cluster_create.json
ERROR: Node Group master is missing 'floating_ip_pool' field
Error ID: d4b6842e-1c3c-4568-8252-c316c0b3ca52


Version-Release number of selected component (if applicable):
ENVIRONMENT: packstack
openstack-packstack-2015.1-0.11.dev1589.g1d6372f.el7ost.noarch

/etc/sahara/sahara.conf
             use_neutron=True
             use_floating_ips=True


[root@sahara sahara(keystone_admin)]# yum info openstack-packstack
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Installed Packages
Name        : openstack-packstack
Arch        : noarch
Version     : 2015.1
Release     : 0.11.dev1589.g1d6372f.el7ost
Size        : 978 k
Repo        : installed
From repo   : rhel-7-server-openstack-7.0-rpms
Summary     : Openstack Install Utility
URL         : https://github.com/stackforge/packstack
Licence     : ASL 2.0 and GPLv2



How reproducible:
1. Create correct master node group template
2. Create worker node group templete (with auto security group and without floating ip pool)
3. Create cluster template
4. Create cluster

Steps to Reproduce:
1. Create json file

cat cluster_create.json 
{
    "name": "cluster-vanilla-1",
    "plugin_name": "vanilla",
    "hadoop_version": "1.2.1",
    "cluster_template_id" : "0595f982-871e-4635-a68d-4209587b9d3e",
    "user_keypair_id": "sahara-key",
    "default_image_id": "e3194119-a7f9-4428-a597-9edbe3af3742",
    "neutron_management_network": "c7982086-7fde-4572-9d8e-a43fc71c3b6f"
}

2. sahara cluster-create --json /root/cluster_create.json
3.

Actual results:
ERROR: Node Group master is missing 'floating_ip_pool' field
Error ID: d4b6842e-1c3c-4568-8252-c316c0b3ca52


Expected results:
Creating cluster

Additional info:

2015-09-10 12:33:33.095 1175 INFO keystonemiddleware.auth_token [-] Auth Token confirmed use of None apis
2015-09-10 12:33:33.300 1175 ERROR sahara.utils.api [-] Validation Error occurred: error_code=400, error_message=Node Group master is missing 'floating_ip_pool' field
Error ID: d4b6842e-1c3c-4568-8252-c316c0b3ca52, error_name=MISSING_FLOATING_NETWORK
2015-09-10 12:33:33.301 1175 INFO sahara.utils.wsgi [-] 192.168.100.115 - - [10/Sep/2015 12:33:33] "POST /v1.1/1bb50bd4ecef442dbc1905a9462a9f13/clusters HTTP/1.1" 400 325 0.210129
Comment 3 Luigi Toscano 2015-09-10 07:22:13 EDT
Please note that vanilla plugin is not supported (and 1.2.1 even less).

That said, if you use use_floating_ips=True, you need to specify the floating IP pool, because Sahara requires it connect to the nodes. So I'm not sure that the error is... wrong.
Comment 4 Edu Alcaniz 2015-09-10 07:28:56 EDT
you can do it well using UI but not in command line.


[root@sahara ~(keystone_admin)]# sahara node-group-template-create --json ng_master_template_create.json 
ERROR: Floating IP pool ext-net not found
Error ID: da9b4523-fb77-463f-9954-5c094e92eb78



[root@sahara ~(keystone_admin)]# cat ng_master_template_create.json 
{
    "name": "master-vanilla-121-tmpl1",
    "flavor_id": "2",
    "plugin_name": "vanilla",
    "hadoop_version": "1.2.1",
    "node_processes": ["jobtracker", "namenode"],
    "auto_security_group": true,
    "floating_ip_pool" : "ext-net"
}

[root@sahara ~(keystone_admin)]# neutron net-list
+--------------------------------------+------------+-------------------------------------------------------+
| id                                   | name       | subnets                                               |
+--------------------------------------+------------+-------------------------------------------------------+
| c7982086-7fde-4572-9d8e-a43fc71c3b6f | Net-sahara | 4a3cc517-4e3f-49f8-a2e1-00c7f440c5c7 192.168.103.0/24 |
| 04946cae-672c-4b34-9f59-3b6066cdef0f | ext-net    | 41d47130-4a1a-4e72-82b1-bb9d7e1370e4 192.168.100.0/24 |
Comment 5 Edu Alcaniz 2015-09-10 07:35:46 EDT
ok, its needs ID of the network. 

[root@sahara ~(keystone_admin)]# sahara node-group-template-create --json ng_master_template_create.json 
+---------------------------+--------------------------------------+
| Property                  | Value                                |
+---------------------------+--------------------------------------+
| volume_local_to_instance  | False                                |
| volumes_availability_zone | None                                 |
| availability_zone         | None                                 |
| volume_mount_prefix       | /volumes/disk                        |
| plugin_name               | vanilla                              |
| floating_ip_pool          | 04946cae-672c-4b34-9f59-3b6066cdef0f |
| is_default                | False                                |
| volumes_size              | 0                                    |
| is_proxy_gateway          | False                                |
| volumes_per_node          | 0                                    |
| hadoop_version            | 1.2.1                                |
| id                        | 6fd544f8-976d-4bd9-8460-873fea418a9a |
| security_groups           | None                                 |
| name                      | master-vanilla-121-tmpl1             |
| tenant_id                 | 1bb50bd4ecef442dbc1905a9462a9f13     |
| created_at                | 2015-09-10 11:29:50.068912           |
| volume_type               | None                                 |
| node_processes            | jobtracker, namenode                 |
| flavor_id                 | 2                                    |
| node_configs              | {}                                   |
| auto_security_group       | True                                 |
+---------------------------+--------------------------------------+

sorry. all works now

Note You need to log in before you can comment on or make changes to this bug.