Bug 1261877 - RuntimeException: Failed managing transaction - occurs when refreshing host capabilities and powering off VM.
RuntimeException: Failed managing transaction - occurs when refreshing host c...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
Unspecified Unspecified
medium Severity medium
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Martin Betak
Nisim Simsolo
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 07:08 EDT by Nisim Simsolo
Modified: 2016-04-19 21:11 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:11:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Virt
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (1.00 MB, text/plain)
2015-09-10 07:10 EDT, Nisim Simsolo
no flags Details
server.log (2.96 MB, text/plain)
2015-09-16 07:29 EDT, Nisim Simsolo
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46219 master MERGED core: Fix order of DB operations in RefreshHostDevicesCommand Never
oVirt gerrit 46227 ovirt-engine-3.6 MERGED core: Fix order of DB operations in RefreshHostDevicesCommand Never

  None (edit)
Description Nisim Simsolo 2015-09-10 07:08:33 EDT
Description of problem:
"Exception: java.lang.RuntimeException: Failed managing transaction" observed on engine.log when doing different engine actions (so far I observed it during host refresh capabilities and powering off suspended VM).
During this exception webadmin functionality is not affected.

Version-Release number of selected component (if applicable):
rhevm-3.6.0-0.13.master.el6
sanlock-3.2.4-1.el7.x86_64
qemu-kvm-rhev-2.3.0-22.el7.x86_64
vdsm-4.17.5-1.el7ev.noarch
libvirt-client-1.2.17-5.el7.x86_64

How reproducible:
Consistently. 

Steps to Reproduce:
1. Open webadmin and refresh host capabilities.
2. Power off suspended VM
3.

Actual results:
Next exception observed on engine log (not sure how it's affecting engine functionality):
2015-09-10 13:53:49,369 ERROR [org.ovirt.engine.core.bll.hostdev.RefreshHostDevicesCommand] (org.ovirt.thread.pool-7-thread-37) [970b11f] Command 'org.ovirt.engine.core.bll.hostdev.RefreshHostDevicesCommand' failed: Failed managing transaction
2015-09-10 13:53:49,369 ERROR [org.ovirt.engine.core.bll.hostdev.RefreshHostDevicesCommand] (org.ovirt.thread.pool-7-thread-37) [970b11f] Exception: java.lang.RuntimeException: Failed managing transaction
.
.
.
Caused by: javax.transaction.RollbackException: ARJUNA016053: Could not commit transaction.

Expected results:
Exception should not occur.

Additional info:
engine.log attached.
Powering off VM event time: 2015-09-10 13:52:12
Refreshing host capability event time: 2015-09-10 13:53:48
Comment 1 Nisim Simsolo 2015-09-10 07:10:19 EDT
Created attachment 1072099 [details]
engine.log
Comment 2 Martin Betak 2015-09-14 10:29:54 EDT
Hi Nisim,

From the error code: 'ARJUNA016053: Could not commit transaction' this seems to be failure of the underlying JBoss transaction manager.

I tried to reproduce this both on Wildfly and on EAP 6.4 but still could not manage to simulate the failure. Are you sure this happens consistently for you? 

Thanks,

Martin
Comment 3 Nisim Simsolo 2015-09-16 03:45:03 EDT
Hi Martin
This issue happens consistently. 
jboss EAP build: JBoss EAP 6.4.3.GA (AS 7.5.3.Final-redhat-2)
Verified using the next command: grep EAP /var/log/ovirt-engine/server.log
Comment 4 Nisim Simsolo 2015-09-16 07:29:32 EDT
Created attachment 1073982 [details]
server.log
Comment 5 Martin Betak 2015-09-16 07:53:42 EDT
Ok, from the server.logs I can see now the underlying cause. Patch posted upstream.
Comment 6 Nisim Simsolo 2015-11-01 08:43:46 EST
Verified: 
rhevm-3.6.0.1-0.1.el6 (3.6.0-17)

Note You need to log in before you can comment on or make changes to this bug.