Bug 1261898 - [RFE] Retrieve Reporting reports from RESTapi
[RFE] Retrieve Reporting reports from RESTapi
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: API (Show other bugs)
5.4.0
Unspecified Unspecified
high Severity high
: GA
: 5.4.3
Assigned To: Tim Wade
Milan Falešník
: FutureFeature, ZStream
Depends On: 1238268 1244937
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 08:10 EDT by Chris Pelland
Modified: 2015-10-22 10:33 EDT (History)
8 users (show)

See Also:
Fixed In Version: 5.4.3.0
Doc Type: Enhancement
Doc Text:
The new version of CloudForms Management Engine adds the capability to retrieve Reporting reports with RESTapi. The reports are returned in the JSON format in response to port standard RESTapi inventory calls.
Story Points: ---
Clone Of: 1238268
Environment:
Last Closed: 2015-10-22 10:33:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Milan Falešník 2015-10-06 07:32:27 EDT
I generated a couple of canned reports in 5.4.3.0, looked for the IDs of them in https://hostname/api/reports?expand=resources and then based on ID, I did https://hostname/api/reports/<id>/results , where I found a list of results and when I opened a particular result with https://hostname/api/reports/<id>/results/<id> I saw a JSON that looks like table data.

\o/
Comment 5 errata-xmlrpc 2015-10-22 10:33:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1916.html

Note You need to log in before you can comment on or make changes to this bug.