Bug 1261900 - Build the dell_rbu module
Build the dell_rbu module
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
Unspecified Linux
unspecified Severity low
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 08:11 EDT by Major Hayden
Modified: 2016-09-26 10:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-26 10:24:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Major Hayden 2015-09-10 08:11:27 EDT
I'd like to see the dell_rbu module enabled again in the Fedora kernel.  I originally brought this up on the mailing list[1], but I figured it would be a good idea to make a ticket.

Bug 997149 cropped up in Fedora 20 which caused the dell_rbu module to be commented out.  However, I've been using Fedora kernels on several Dell and non-Dell servers with the dell_rbu module enabled.  I haven't seen any issues during installation or after the system is running.

Enabling it will allow users of Dell hardware to update their firmware much more easily from within a running Linux OS.

FWIW, I have this built in a COPR[2].

[1] https://lists.fedoraproject.org/pipermail/kernel/2015-August/005986.html
[2] https://copr.fedoraproject.org/coprs/mhayden/kernel-dellrbu/
Comment 1 Josh Boyer 2015-09-10 08:26:25 EDT
Right.  So the problem with bug 997149 was that udev no longer supports being the user helper for firmware loading.  Like, at all.  None of the patches to either fix dell_rbu or to work around the fact that userspace doesn't actually do the user helper part ever went anywhere.

So when you say you haven't seen any issues, I'm curious on a couple of things.

1) Is the dell_rbu driver in the initramfs and is it being loaded on boot from there?

2) Is the dell_rbu driver being loaded automatically at all?

3) Are you seeing any 60 second hangs while firmware is requested and nothing is handling it?  This might be difficult to notice if the module is loaded well after you've booted.

4) Have you actually used the dell_rbu driver to update the firmware on a Dell machine?

I'm really not wild about enabling CONFIG_FW_LOADER_USER_HELPER again.
Comment 2 Major Hayden 2015-09-10 10:15:06 EDT
I hear ya on the CONFIG_FW_LOADER_USER_HELPER part for sure. ;)

1) It's not in the initramfs.  I could probably try that and let you know.

2) It's not being loaded automatically.  I've only loaded it manually with modprobe.

3) No, but that could be due to the fact I'm loading it later.

4) Updated a Dell PowerEdge 710 earlier this year on Fedora 22 and updated an Optiplex 3020 a few weeks ago on Fedora 22.

I wonder if there's a way to add it to a modules-extra package or something like that to avoid having it on a system causing trouble by default.
Comment 3 Laura Abbott 2016-09-23 15:20:37 EDT
*********** MASS BUG UPDATE **************
 
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 23 kernel bugs.
 
Fedora 23 has now been rebased to 4.7.4-100.fc23.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 24 or 25, and are still experiencing this issue, please change the version to Fedora 24 or 25.
 
If you experience different issues, please open a new bug report for those.

Note You need to log in before you can comment on or make changes to this bug.