Bug 1261912 - [RFE] Enable AD/ADFS support in RGW
[RFE] Enable AD/ADFS support in RGW
Status: CLOSED ERRATA
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW (Show other bugs)
1.3.0
All Linux
medium Severity medium
: rc
: 2.0
Assigned To: Matt Benjamin (redhat)
shylesh
Bara Ancincova
: FutureFeature, Triaged
: 1244737 (view as bug list)
Depends On:
Blocks: 1322504
  Show dependency treegraph
 
Reported: 2015-09-10 08:19 EDT by Vimal Kumar
Modified: 2017-07-30 12:04 EDT (History)
15 users (show)

See Also:
Fixed In Version: RHEL: ceph-10.2.0-1.el7cp
Doc Type: Enhancement
Doc Text:
Documented with BZ#1261891
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-23 15:26:21 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1758493 None None None Never

  None (edit)
Comment 2 Neil Levine 2015-09-22 14:47:07 EDT
*** Bug 1244737 has been marked as a duplicate of this bug. ***
Comment 6 Marcus Watts 2016-03-14 18:21:01 EDT
STS is NOT in master or v10.0.3.  And not in the "jewel" branch by March 9th.  The current plan is to target kraken & backport to jewel.
Comment 7 Neil Levine 2016-03-14 19:03:48 EDT
Ths card refers to the native AD support, not STS.

STS is covered under https://bugzilla.redhat.com/show_bug.cgi?id=1274084
Comment 8 Ken Dreyer (Red Hat) 2016-04-26 16:44:38 EDT
Matt, is this feature complete in v10.2.0?
Comment 9 Ken Dreyer (Red Hat) 2016-05-10 16:32:30 EDT
This is AD LDAP support, not STS.

From the call today: It is in v10.2.0
Comment 15 shylesh 2016-08-04 11:36:49 EDT
Verified with AD on Windows 2012. All the targeted tests are complete hence marking this as verified.

Special thanks to Matt for providing his AD setup for testing.
Comment 17 errata-xmlrpc 2016-08-23 15:26:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1755

Note You need to log in before you can comment on or make changes to this bug.