Bug 1261920 - introspection should skip nodes that are in maintenance mode
introspection should skip nodes that are in maintenance mode
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: ga
: 8.0 (Liberty)
Assigned To: Dmitry Tantsur
Udi
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 08:43 EDT by Udi
Modified: 2016-04-07 17:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: python-tripleoclient-0.1.1-2
Doc Type: Bug Fix
Doc Text:
Previously, bulk introspection operated on nodes currently in maintenance mode. This could cause introspection to fail, or even break node maintenance (depending on the reason for node maintenance). With this release, bulk introspection now ignores nodes in maintenance mode.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 17:39:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 235148 None None None Never

  None (edit)
Description Udi 2015-09-10 08:43:38 EDT
Description of problem:
I had 2 nodes in set with maintenance=true in ironic, due to the fact that their ipmi password in instackenv.json was wrong. They were skipped properly by "openstack baremetal configure boot", but when I ran introspection they were not skipped - and of course introspection failed for these 2 nodes.


Version-Release number of selected component (if applicable):
python-rdomanager-oscplugin-0.0.10-1.el7ost.noarch
openstack-ironic-discoverd-1.1.0-6.el7ost.noarch
python-ironicclient-0.5.1-10.el7ost.noarch
openstack-ironic-common-2015.1.1-4.el7ost.noarch
openstack-ironic-conductor-2015.1.1-4.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Register nodes and put a few in maintenance mode
2. Run the "configure boot" and introspection commands


Actual results:
The system attempts to introspect the nodes that are in maintenance


Expected results:
Nodes in maintenance should be skipped by introspection
Comment 4 James Slagle 2015-10-14 15:49:52 EDT
dmitry, I believe this fix would be in the inspector client?
Comment 5 Dmitry Tantsur 2015-10-15 03:22:07 EDT
Hi! Maintenance mode is accepted by ironic-inspector for compatibility reason, this will be removed in Mitaka. The real problem is that 'introspection bulk start' command tries to use this nodes, which seems to be a problem in rdomanager-oscclient and should be fixed there.
Comment 6 Dmitry Tantsur 2016-01-04 10:21:38 EST
Fixed in stable/liberty upstream, not sure what state to assign..
Comment 7 Dmitry Tantsur 2016-02-02 08:59:59 EST
The fix is available now
Comment 9 Udi 2016-02-28 06:17:50 EST
Verified in:
openstack-ironic-common-4.2.2-4.el7ost.noarch
python-ironicclient-0.8.1-1.el7ost.noarch
Comment 11 errata-xmlrpc 2016-04-07 17:39:34 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0604.html

Note You need to log in before you can comment on or make changes to this bug.