Bug 126193 - ttys black since upgrade to 2.6.6-1.435
Summary: ttys black since upgrade to 2.6.6-1.435
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 2
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-06-17 10:06 UTC by Stephan Menzel
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-17 12:27:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel .config that created the faulty kernel (24.66 KB, text/plain)
2004-06-17 10:08 UTC, Stephan Menzel
no flags Details

Description Stephan Menzel 2004-06-17 10:06:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040603

Description of problem:
since I did the upgrade to 2.6.6-1.435 (from the previous
2.6.6-1.427custom) and compiled my new kernel using my old .config
(after doing make oldconfig of course) all the non-graphic ttys are
black on black. They still work so I can enter commands, but I can't
see anything.
I attach my .config.
The only thing I did in that time was the kernel upgrade so it must
have something to do with it.
After booting, you can shortly see the tty and when kdm kicks in, they
disappear and don't come back.

Stephan



Version-Release number of selected component (if applicable):
2.6.6-1.435custom

How reproducible:
Always

Steps to Reproduce:
1. compile kernel
2. boot it (runleven 5)
3. switch to tty and see nothing
    

Actual Results:  If I try to switch to a non-graphic tty, I can't see
anything. It's possible to enter commands though.

Expected Results:  Visible ttys

Additional info:

Booting the distri-kernel 2.6.6-1.435 the problem doesn't exist.

Comment 1 Stephan Menzel 2004-06-17 10:08:28 UTC
Created attachment 101212 [details]
kernel .config that created the faulty kernel

This .config creates my kernel. It is the same I always used without
experiencing troubles. I do make oldconfig all the time before an update.

Comment 2 Dave Jones 2004-06-17 10:58:03 UTC
You enable framebuffer but...

# CONFIG_FRAMEBUFFER_CONSOLE is not set

Which would explain why its invisible. Don't know why it worked before.

Comment 3 Stephan Menzel 2004-06-17 12:03:43 UTC
That works indeed. 
Thanks. However, I'm really using that configuration for ages now. 
Imported it from RedHat9 and used through many different kernel 
versions. Strange. 
 
Stephan 
 
 


Note You need to log in before you can comment on or make changes to this bug.