Bug 1261986 - [abrt] libreoffice-core: operator[](): soffice.bin killed by SIGABRT
[abrt] libreoffice-core: operator[](): soffice.bin killed by SIGABRT
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openoffice.org-diafilter (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:56b076156c415bed375e2d4274f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 10:41 EDT by JDP803
Modified: 2015-10-13 13:03 EDT (History)
7 users (show)

See Also:
Fixed In Version: openoffice.org-diafilter-1.7.4-1.fc23 openoffice.org-diafilter-1.7.4-1.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-07 12:36:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (72.14 KB, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: cgroup (190 bytes, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: core_backtrace (20.91 KB, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: dso_list (21.63 KB, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: environ (2.08 KB, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: limits (1.29 KB, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: maps (109.27 KB, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: mountinfo (3.82 KB, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: namespaces (85 bytes, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: open_fds (4.86 KB, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: proc_pid_status (1018 bytes, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File: var_log_messages (321 bytes, text/plain)
2015-09-10 10:41 EDT, JDP803
no flags Details
File opened by libreoffice during crash. (3.22 KB, application/x-gzip)
2015-09-11 10:45 EDT, JDP803
no flags Details

  None (edit)
Description JDP803 2015-09-10 10:41:00 EDT
Description of problem:


Version-Release number of selected component:
libreoffice-core-4.4.5.2-1.fc22

Additional info:
reporter:       libreport-2.6.2
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin -draw /home/jason/Documents/amers_toba.dia --splash-pipe=5
crash_function: operator[]
executable:     /usr/lib64/libreoffice/program/soffice.bin
global_pid:     16469
kernel:         4.1.6-200.fc22.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000

Truncated backtrace:
Thread no. 1 (10 frames)
 #4 operator[] at /usr/lib64/libreoffice/sdk/include/rtl/ustring.hxx:429
 #5 lcl_getDoubleChar at src/basegfx/b2dsvgpolypolygon.cxx:86
 #6 basegfx::tools::(anonymous namespace)::lcl_importDoubleAndSpaces at src/basegfx/b2dsvgpolypolygon.cxx:139
 #7 basegfx::tools::importFromSvgPoints at src/basegfx/b2dsvgpolypolygon.cxx:804
 #8 createViewportAndPolygonFromPoints at src/shapefilter.cxx:262
 #10 (anonymous namespace)::makeArrow at src/diafilter.cxx:584
 #11 DiaImporter::handleDiagram at src/diafilter.cxx:3799
 #12 DiaImporter::convert at src/diafilter.cxx:3838
 #13 DIAFilter::filter at src/diafilter.cxx:3916
 #14 gcc3::callVirtualMethod at /usr/src/debug/libreoffice-4.4.5.2/bridges/source/cpp_uno/gcc3_linux_x86-64/callvirtualmethod.cxx:122
Comment 1 JDP803 2015-09-10 10:41:05 EDT
Created attachment 1072224 [details]
File: backtrace
Comment 2 JDP803 2015-09-10 10:41:06 EDT
Created attachment 1072225 [details]
File: cgroup
Comment 3 JDP803 2015-09-10 10:41:08 EDT
Created attachment 1072226 [details]
File: core_backtrace
Comment 4 JDP803 2015-09-10 10:41:09 EDT
Created attachment 1072227 [details]
File: dso_list
Comment 5 JDP803 2015-09-10 10:41:10 EDT
Created attachment 1072228 [details]
File: environ
Comment 6 JDP803 2015-09-10 10:41:11 EDT
Created attachment 1072229 [details]
File: limits
Comment 7 JDP803 2015-09-10 10:41:15 EDT
Created attachment 1072230 [details]
File: maps
Comment 8 JDP803 2015-09-10 10:41:17 EDT
Created attachment 1072231 [details]
File: mountinfo
Comment 9 JDP803 2015-09-10 10:41:18 EDT
Created attachment 1072232 [details]
File: namespaces
Comment 10 JDP803 2015-09-10 10:41:19 EDT
Created attachment 1072233 [details]
File: open_fds
Comment 11 JDP803 2015-09-10 10:41:20 EDT
Created attachment 1072234 [details]
File: proc_pid_status
Comment 12 JDP803 2015-09-10 10:41:21 EDT
Created attachment 1072235 [details]
File: var_log_messages
Comment 13 David Tardon 2015-09-10 11:17:48 EDT
Could you attach the crashing file here?
Comment 14 JDP803 2015-09-10 13:07:12 EDT
(In reply to David Tardon from comment #13)
> Could you attach the crashing file here?

Honestly, after looking at this further, I see that this was due to "dia" not being installed. Seems that libreoffice attempted to open the file which it isn't designed to handle. This should be closed. Apologies.
Comment 15 David Tardon 2015-09-11 02:11:35 EDT
LibreOffice _can_ open dia files, via openoffice.org-diafilter extension. Otherwise there'd have been no crash.
Comment 16 JDP803 2015-09-11 10:45:40 EDT
Created attachment 1072578 [details]
File opened by libreoffice during crash.
Comment 17 Fedora Update System 2015-09-15 07:46:59 EDT
openoffice.org-diafilter-1.7.4-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15889
Comment 18 Fedora Update System 2015-09-15 08:03:20 EDT
openoffice.org-diafilter-1.7.4-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-15891
Comment 19 Fedora Update System 2015-09-15 12:50:24 EDT
openoffice.org-diafilter-1.7.4-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update openoffice.org-diafilter'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15889
Comment 20 Fedora Update System 2015-09-15 18:56:19 EDT
openoffice.org-diafilter-1.7.4-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update openoffice.org-diafilter'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-15891
Comment 21 Fedora Update System 2015-10-07 12:36:51 EDT
openoffice.org-diafilter-1.7.4-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2015-10-13 13:03:28 EDT
openoffice.org-diafilter-1.7.4-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.