Bug 1262004 - [Labels] > sub tab - Edit icon (pencil) is missing on labeled network after detaching it from NIC via Setup Networks
[Labels] > sub tab - Edit icon (pencil) is missing on labeled network after d...
Status: CLOSED NOTABUG
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin (Show other bugs)
---
x86_64 Linux
low Severity low (vote)
: ovirt-4.0.0-alpha
: ---
Assigned To: Alona Kaplan
Michael Burman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 11:01 EDT by Michael Burman
Modified: 2016-03-28 03:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-28 03:31:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ylavi: ovirt‑4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)
record (1.99 MB, application/ogg)
2015-09-10 11:01 EDT, Michael Burman
no flags Details

  None (edit)
Description Michael Burman 2015-09-10 11:01:47 EDT
Created attachment 1072242 [details]
record

Description of problem:
[Labels] > sub tab - Edit icon (pencil) is missing on labeled network after detaching it from NIC via Setup Networks.

After detaching a labeled network from a NIC on host via Setup Networks, the edit pencil icon is missing on the network on the labels sub tab in SN.

Version-Release number of selected component (if applicable):
3.6.0-0.13.master.el6

How reproducible:
100

Steps to Reproduce:
1. Attach labeled network to NIC via SN(icon pencil exist on network)
2. Detach the labeled network from NIC 

Actual results:
On the labels sub tab, the edit icon (pencil) is missing on the network. 

Expected results:
The edit icon (pencil) should remain on the network, like it was before  
attaching to NIC, and like was on the attached NIC.
Comment 1 Dan Kenigsberg 2016-03-27 06:22:03 EDT
Does this also happen in your newly-refactored dialog?
Comment 2 Alona Kaplan 2016-03-27 07:19:17 EDT
Yes, it still happens.
But the bug is not the pencil is missing. The bug is there was a pencil in the first place.
A detached network, whether it has label or not, shouldn't be editable.
The edit dialog is used to edit the attachment. There is no attachment on detached network, so it doesn't make sense to edit it.

The scenario in the bug is not accurate. Most of the labeled detached networks don't have the edit pencil when they are detached in any stage (before attaching and after detaching). The problematic case is when a network is already attached to a nic (not via label). And also have a label (that is not on any host nic).
In this case the network is actually attached, that's why it is editable.
There are two panel that represent the same network, one attached to the nic and the other in the detached labels dialog.
The panel in the detached labels dialog shouldn't have the edit button.
The reason it disappears when attaching the label to a nic and then detaching it, is that the network is removed from the nic it was attached to before, and attaches just to the new nic with the label.
Now when detaching the label, the network is actually detached and not attached to any nic. That's why the edit icon disappears.
Comment 3 Dan Kenigsberg 2016-03-28 03:31:17 EDT
Given comment 2 I understand that currently the pencil shows up if-and-only-if the network is currently attached to a host nic. The network disappears from the unattached-labels pane when its label is attached to the host; when the label is detached, the network returns but now it is no longer attached to any nic.

In my opinion, the current logic (show pencil iff network is attached to host) is sane and simple and should be kept whereever the network is shown.

Note You need to log in before you can comment on or make changes to this bug.