This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1262024 - IP Address of VMware host not found
IP Address of VMware host not found
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.4.0
Unspecified Unspecified
medium Severity low
: GA
: 5.4.3
Assigned To: Adam Grare
Jan Krocil
: ZStream
Depends On: 1260139
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 11:32 EDT by Chris Pelland
Modified: 2015-10-22 10:33 EDT (History)
11 users (show)

See Also:
Fixed In Version: 5.4.3.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1260139
Environment:
Last Closed: 2015-10-22 10:33:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 CFME Bot 2015-09-28 08:18:16 EDT
New commit detected on cfme/5.4.z:
https://code.engineering.redhat.com/gerrit/gitweb?p=cfme.git;a=commitdiff;h=4e4eb3762fa927a5c79d5e0b77addc4a2314c673

commit 4e4eb3762fa927a5c79d5e0b77addc4a2314c673
Merge: d3513f8 af1c19d
Author:     Greg Blomquist <gblomqui@redhat.com>
AuthorDate: Mon Sep 28 08:16:14 2015 -0400
Commit:     Greg Blomquist <gblomqui@redhat.com>
CommitDate: Mon Sep 28 08:16:14 2015 -0400

    Merge branch 'vmware_host_ip_address' into '5.4.z'
    
    Fix IP address lookup on VMware hosts
    
    Fix for missing ip address on vmware hosts due to ||= returning
    an empty array.
    https://bugzilla.redhat.com/show_bug.cgi?id=1262024
    
    See merge request !250

 vmdb/app/models/ems_refresh/parsers/vc.rb | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)
Comment 6 Pete Savage 2015-10-09 09:36:45 EDT
Verified in 5.4.3.0

We commented out resolv.conf and added a vsphere provider by IP, the hosts were correctly populated with the hostname/ip, whereas on the 5.4.1.0 build the hostname was put into both fields.
Comment 8 errata-xmlrpc 2015-10-22 10:33:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1916.html

Note You need to log in before you can comment on or make changes to this bug.