Bug 1262093 - [RFE] Improve Solaris 10 (x86-64) support in virt-manager
[RFE] Improve Solaris 10 (x86-64) support in virt-manager
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-10 15:29 EDT by Jan Vlug
Modified: 2015-12-28 18:55 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-manager-1.2.1-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-28 18:55:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
virt-manager configuration file for a working Solaris 10 guest (3.95 KB, text/html)
2015-09-10 15:30 EDT, Jan Vlug
no flags Details

  None (edit)
Description Jan Vlug 2015-09-10 15:29:37 EDT
Currently, the support for a Solaris 10 (x86-64) guest virtual machine in virt-manager is limited. The default configuration results in a non-functioning guest.

Provide a working guest configuration for Solaris 10 through virt-manager, based on the suggestions below.

Solaris 10 is here available for download:
http://www.oracle.com/technetwork/server-storage/solaris10/downloads/index.html

Solaris 10 system requirements:
http://www.oracle.com/technetwork/server-storage/solaris/overview/specs-jsp-136480.html

Requested improvements (changes compared to current defaults):
1. Detect the Solaris 10 operating system automatically
   ISO file name: sol-10-u11-ga-x86-dvd.iso
2. Set guest name to solaris10
3. RAM: 2048MB
3. Video: Cirrus
4. In order to have the network working (see bug #1040500):
   Add <cpu> feature:
   <feature name="x2apic" policy="disable"/>
5. SandyBridge and Haswell-noTSX worked for me as CPU, I did not test other CPUs.

I selected the defaults for all other settings (except for that I had to add the boot iso, and change the boot order after making the config changes).

See also:
Bug #1040500
https://www.redhat.com/archives/virt-tools-list/2015-September/msg00025.html
http://pve.proxmox.com/wiki/Solaris_Guests#Solaris_10

This display hardware did not work:
VGA
VMVGA

I did not test the audio hardware, nor the spice devices. Maybe they should be removed from a configuration for Solaris 10.
Comment 1 Jan Vlug 2015-09-10 15:30:37 EDT
Created attachment 1072357 [details]
virt-manager configuration file for a working Solaris 10 guest
Comment 2 Cole Robinson 2015-11-03 16:03:10 EST
Thanks for the report, fixed upstream now:

commit b7e073a407451e1f3e16e98d97357802cf6b3657
Author: Cole Robinson <crobinso@redhat.com>
Date:   Tue Nov 3 11:15:26 2015 -0500

    osdict: Disable x2apic for solaris10 (bz 1262093)


I didn't change the video default, because in my testing qxl worked quite fine.
Comment 3 Fedora Update System 2015-11-25 15:28:32 EST
virt-manager-1.2.1-3.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-cdb691dcd9
Comment 4 Fedora Update System 2015-11-26 17:54:04 EST
virt-manager-1.2.1-3.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update virt-manager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-cdb691dcd9
Comment 5 Fedora Update System 2015-11-27 20:15:43 EST
virt-manager-1.2.1-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-ad893bbf01
Comment 6 Fedora Update System 2015-11-28 19:54:42 EST
virt-manager-1.2.1-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update virt-manager'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-ad893bbf01
Comment 7 Fedora Update System 2015-12-28 18:55:07 EST
virt-manager-1.2.1-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.