Bug 1262111 - ipmitool: unnecessary dependencies.
ipmitool: unnecessary dependencies.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ipmitool (Show other bugs)
6.8
All Linux
urgent Severity high
: rc
: ---
Assigned To: Boris Ranto
Rachel Sibley
: Regression, ZStream
Depends On:
Blocks: 1172231 1269875
  Show dependency treegraph
 
Reported: 2015-09-10 16:11 EDT by Thomas Gardner
Modified: 2016-05-10 16:08 EDT (History)
4 users (show)

See Also:
Fixed In Version: ipmitool-1.8.15-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1269875 (view as bug list)
Environment:
Last Closed: 2016-05-10 16:08:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 1162175 None None None Never

  None (edit)
Description Thomas Gardner 2015-09-10 16:11:02 EDT
Description of problem:
ipmitool gained a dependency on the OpenIPMI package.  This causes a flood of new, unneeded packages on some systems.

Version-Release number of selected component (if applicable):

Additional info:
This was supposed to have been fixed with BZ#1162175, but, well, wasn't.  Really, this is a one line change in the .spec file to remove this dependency.
Comment 2 Thomas Gardner 2015-09-14 05:28:12 EDT
Apparently, the developer assigned to this case is out on sick leave.  I'm guessing this assignment was made automatically.  Would someone please assign a different developer?
Comment 5 Rachel Sibley 2016-02-12 16:44:12 EST
ALL TESTS PASSED

Before:
=========================
$  rpm --test -i ipmitool-1.8.13-8.el7_1.x86_64.rpm
error: Failed dependencies:
	OpenIPMI-modalias is needed by ipmitool-1.8.13-8.el7_1.x86_64
$

After:
=========================
$ rpm --test -i  ipmitool-1.8.15-1.el6.x86_64.rpm
$

- No longer displaying Requires: OpenIPMI
$ grep -i openipmi ipmitool-1.8.15/ipmitool.spec 
kernel driver such as OpenIPMI or over the RMCP LAN protocol defined in
   by OpenIPMI
 - Add LUN support to OpenIPMI interface
 - Add support for FreeBSD OpenIPMI-compatible driver
 - Overhaul to ipmievd to support SEL polling in addition to OpenIPMI.
Comment 7 errata-xmlrpc 2016-05-10 16:08:17 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-0771.html

Note You need to log in before you can comment on or make changes to this bug.